summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-01-12 15:14:50 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-01-12 15:14:50 +0000
commitf63a4e6c4690eea28075e25480a52d98cbceed31 (patch)
treee034a204c8a8f491922f86445009b378fad584e8 /app-i18n
parentkeyword ~ppc,~ppc64 wrt #348192 (diff)
downloadhistorical-f63a4e6c4690eea28075e25480a52d98cbceed31.tar.gz
historical-f63a4e6c4690eea28075e25480a52d98cbceed31.tar.bz2
historical-f63a4e6c4690eea28075e25480a52d98cbceed31.zip
Fixed header to work with app-i18n/im-ja. Added static-libs USE flag and canna-2ch local USE flag.
Package-Manager: portage-2.1.9.28/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy/ChangeLog11
-rw-r--r--app-i18n/anthy/anthy-9100h-r1.ebuild64
-rw-r--r--app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch12
-rw-r--r--app-i18n/anthy/metadata.xml3
4 files changed, 88 insertions, 2 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 22660c48fcc3..84c45b653d6c 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/anthy
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.131 2010/11/25 12:30:06 hattya Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.132 2011/01/12 15:14:50 matsuu Exp $
+
+*anthy-9100h-r1 (12 Jan 2011)
+
+ 12 Jan 2011; MATSUU Takuto <matsuu@gentoo.org> +anthy-9100h-r1.ebuild,
+ +files/anthy-9100h-anthy_context_t.patch, metadata.xml:
+ Fixed header to work with app-i18n/im-ja. Added static-libs USE flag and
+ canna-2ch local USE flag.
25 Nov 2010; Akinori Hattori <hattya@gentoo.org>
-files/anthy-7500b-asneeded.patch, -files/anthy-mkdic-gcc34.patch,
diff --git a/app-i18n/anthy/anthy-9100h-r1.ebuild b/app-i18n/anthy/anthy-9100h-r1.ebuild
new file mode 100644
index 000000000000..fdfb90f1ac66
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100h-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-9100h-r1.ebuild,v 1.1 2011/01/12 15:14:50 matsuu Exp $
+
+EAPI=3
+inherit elisp-common eutils
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/37536/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+#KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="canna-2ch emacs static-libs"
+
+DEPEND="!app-i18n/anthy-ss
+ canna-2ch? ( app-dicts/canna-2ch )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-anthy_context_t.patch"
+
+ if use canna-2ch; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i \
+ -e "/set_input_encoding eucjp/aread ${EPREFIX}/var/lib/canna/dic/canna/nichan.ctd" \
+ mkworddic/dict.args.in || die
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use emacs ; then
+ elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el || die
+ fi
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog || die
+
+ rm -f doc/Makefile*
+ docinto doc
+ dodoc doc/* || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch b/app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch
new file mode 100644
index 000000000000..b46a136663bc
--- /dev/null
+++ b/app-i18n/anthy/files/anthy-9100h-anthy_context_t.patch
@@ -0,0 +1,12 @@
+diff -Naur anthy-9100h.orig/anthy/input.h anthy-9100h/anthy/input.h
+--- anthy-9100h.orig/anthy/input.h 2006-05-13 18:28:35.000000000 +0900
++++ anthy-9100h/anthy/input.h 2011-01-12 23:36:39.629749518 +0900
+@@ -10,6 +10,8 @@
+ #ifndef INPUT_H_INCLUDE
+ #define INPUT_H_INCLUDE
+
++#include "anthy.h"
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
diff --git a/app-i18n/anthy/metadata.xml b/app-i18n/anthy/metadata.xml
index 85cd1cffb07b..73e1b6781c3e 100644
--- a/app-i18n/anthy/metadata.xml
+++ b/app-i18n/anthy/metadata.xml
@@ -13,4 +13,7 @@
<pkg>app-i18n/uim</pkg> (XIM, GTK+ immodule) and <pkg>virtual/emacs</pkg>
(to enable Anthy support for emacs, build this package with emacs USE flag).
</longdescription>
+<use>
+ <flag name='canna-2ch'>Enable support for <pkg>app-dicts/canna-2ch</pkg></flag>
+</use>
</pkgmetadata>