summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-09-15 11:39:16 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-09-15 11:39:16 +0000
commit03196a5150fd34247be152a270bd0d59347e8561 (patch)
tree09217dda0bfbab22aaac40c90938c73b244c5bac /app-i18n
parentremoving old/deprecated galeon-ebuilds (diff)
downloadhistorical-03196a5150fd34247be152a270bd0d59347e8561.tar.gz
historical-03196a5150fd34247be152a270bd0d59347e8561.tar.bz2
historical-03196a5150fd34247be152a270bd0d59347e8561.zip
version bump
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5714.ebuild69
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-57141
4 files changed, 79 insertions, 2 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index b41bb3abea3e..12c50b01c798 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.47 2004/09/07 12:38:00 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.48 2004/09/15 11:39:16 hattya Exp $
+
+*anthy-ss-5714 (15 Sep 2004)
+
+ 15 Sep 2004; Akinori Hattori <hattya@gentoo.org> +anthy-ss-5714.ebuild:
+ version bump.
*anthy-ss-5701 (07 Sep 2004)
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 2b610046fd7d..6c93858fdfbb 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,11 +1,13 @@
-MD5 8340c97b3f03cafbea995eabeb152fe5 ChangeLog 6428
+MD5 44580138be2a39da8610cd78b526f475 ChangeLog 6549
MD5 685ca99e1830c1c18ef9dcd474aeb690 anthy-ss-5608.ebuild 1516
MD5 9450455211862e1d4be31f74762bc806 anthy-ss-5613.ebuild 1516
MD5 1b87ce8d9b1c27f4da17078b6090deb4 anthy-ss-5626.ebuild 1516
MD5 5deae3ab7744d6f30f7d818dd1173e47 anthy-ss-5701.ebuild 1516
+MD5 59e16299aff2e60834b8f74767855f38 anthy-ss-5714.ebuild 1516
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 5d67456010e53e1c3ac13fbb21bc43cd files/digest-anthy-ss-5608 63
MD5 4f29f88aefb078e637262bb3574ebdde files/digest-anthy-ss-5613 63
MD5 b138cf04ba4c5ff57d888a4bd92828da files/digest-anthy-ss-5626 63
MD5 656e28a61e3969c1576cdc07ddfd560a files/digest-anthy-ss-5701 63
+MD5 c46e2a82231884e714d609923e5ee847 files/digest-anthy-ss-5714 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5714.ebuild b/app-i18n/anthy-ss/anthy-ss-5714.ebuild
new file mode 100644
index 000000000000..b6b6199eaa7b
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5714.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5714.ebuild,v 1.1 2004/09/15 11:39:16 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/11386/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5714 b/app-i18n/anthy-ss/files/digest-anthy-ss-5714
new file mode 100644
index 000000000000..e6624513d4a5
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5714
@@ -0,0 +1 @@
+MD5 f0fd23e28139c25f6449649e38a349af anthy-5714.tar.gz 1550063