summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-28 23:23:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-28 23:23:47 +0000
commitd00a2568315099a53ab949742946a7e72ab609d8 (patch)
tree5e3d94a0eb3289ca80febac8c344fef35fe58f40 /app-i18n/scim-anthy
parentChange local rhino USE flag to global javascript flag with the same meaning. ... (diff)
downloadhistorical-d00a2568315099a53ab949742946a7e72ab609d8.tar.gz
historical-d00a2568315099a53ab949742946a7e72ab609d8.tar.bz2
historical-d00a2568315099a53ab949742946a7e72ab609d8.zip
Version bumped.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'app-i18n/scim-anthy')
-rw-r--r--app-i18n/scim-anthy/ChangeLog7
-rw-r--r--app-i18n/scim-anthy/files/digest-scim-anthy-1.2.43
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.4.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index e88cbf0a6de9..d43bb111d2d9 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-anthy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.45 2007/05/06 04:50:22 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.46 2007/05/28 23:22:40 matsuu Exp $
+
+*scim-anthy-1.2.4 (28 May 2007)
+
+ 28 May 2007; MATSUU Takuto <matsuu@gentoo.org> +scim-anthy-1.2.4.ebuild:
+ Version bumped.
06 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
scim-anthy-1.2.2.ebuild:
diff --git a/app-i18n/scim-anthy/files/digest-scim-anthy-1.2.4 b/app-i18n/scim-anthy/files/digest-scim-anthy-1.2.4
new file mode 100644
index 000000000000..a5e5716fcca4
--- /dev/null
+++ b/app-i18n/scim-anthy/files/digest-scim-anthy-1.2.4
@@ -0,0 +1,3 @@
+MD5 14c4d620bc5d6744a2fe6ef7d2bf2ecf scim-anthy-1.2.4.tar.gz 649495
+RMD160 5e20bf4b1609c1b5c753f91b74086e00fab027d5 scim-anthy-1.2.4.tar.gz 649495
+SHA256 80a853598ac3ff8a067e4ba99446cef3dcde2f79ec39d59efded3081735b7e14 scim-anthy-1.2.4.tar.gz 649495
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.4.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.4.ebuild
new file mode 100644
index 000000000000..05067b3c33e6
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.4.ebuild,v 1.1 2007/05/28 23:22:40 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/25404/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="kde nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-5900 >=app-i18n/anthy-ss-5911 )
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}
+ app-dicts/kasumi"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+PDEPEND="kde? ( app-i18n/skim-scim-anthy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}