summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-06-04 16:22:21 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-06-04 16:22:21 +0000
commit0ed31e086491d07946d60670e4f1b83116dd464e (patch)
tree753feba0412c2c9808dc8ea24d02c86f4f9d0a2b /app-i18n/ibus-anthy
parentAdded update module for GTK+-2.16. (diff)
downloadhistorical-0ed31e086491d07946d60670e4f1b83116dd464e.tar.gz
historical-0ed31e086491d07946d60670e4f1b83116dd464e.tar.bz2
historical-0ed31e086491d07946d60670e4f1b83116dd464e.zip
Version bumped.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 976081ae4958..05203f6048db 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.8 2009/04/02 16:04:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.9 2009/06/04 16:22:21 matsuu Exp $
+
+*ibus-anthy-1.1.0.20090603 (04 Jun 2009)
+
+ 04 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-anthy-1.1.0.20090603.ebuild:
+ Version bumped.
*ibus-anthy-1.1.0.20090402 (02 Apr 2009)
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild
new file mode 100644
index 000000000000..ab3b1e835af2
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090603.ebuild,v 1.1 2009/06/04 16:22:21 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ app-i18n/anthy
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}