summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-05-25 16:09:37 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-05-25 16:09:37 +0000
commit47f7ce6fae34308fc1f7a691f08fcdad77f7d97d (patch)
tree95af892ef1fa70c96c90e414ff1e8c0bf8286a68 /app-i18n/anthy-ss
parent~amd64 (diff)
downloadhistorical-47f7ce6fae34308fc1f7a691f08fcdad77f7d97d.tar.gz
historical-47f7ce6fae34308fc1f7a691f08fcdad77f7d97d.tar.bz2
historical-47f7ce6fae34308fc1f7a691f08fcdad77f7d97d.zip
version bump.
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5312.ebuild74
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-53121
4 files changed, 84 insertions, 2 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index d2e7e34b3755..8911d2c3b3f2 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.26 2004/04/30 12:15:18 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.27 2004/05/25 16:09:37 hattya Exp $
+
+*anthy-ss-5312 (26 May 2004)
+
+ 26 May 2004; Akinori Hattori <hattya@gentoo.org> anthy-ss-5312.ebuild:
+ version bump.
30 Apr 2004; Akinori Hattori <hattya@gentoo.org> anthy-ss-5117.ebuild,
anthy-ss-5122.ebuild:
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index c9c2dc8fb511..8ecd22038e8e 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,9 +1,11 @@
-MD5 e173706820bc78e703aeb80b41ca9ec4 ChangeLog 3984
+MD5 4d7a91d64c16cb1789ac2bca51c2bfae ChangeLog 4104
MD5 f27b5ea1e7d90424b7486f0ad540753b anthy-ss-5201.ebuild 1488
MD5 6a33087b1a0342d8225d04e3e6856a55 anthy-ss-5226.ebuild 1657
MD5 d02bea48564d5e4d0e0d6be2d1a833ab anthy-ss-5229.ebuild 1658
+MD5 a6ffd28c6d01ed39d7656f108ee10f2f anthy-ss-5312.ebuild 1658
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 2050cbddba611585ca7c9a054528f923 files/digest-anthy-ss-5201 63
MD5 ccb521fe9370bee91694629f0ffa65ee files/digest-anthy-ss-5226 63
MD5 78eb6a503308e1c04c33e88b9bc8cb02 files/digest-anthy-ss-5229 63
+MD5 ed01f6179b92551a1a2cfa0bb10c02b8 files/digest-anthy-ss-5312 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5312.ebuild b/app-i18n/anthy-ss/anthy-ss-5312.ebuild
new file mode 100644
index 000000000000..8953f188833d
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5312.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5312.ebuild,v 1.1 2004/05/25 16:09:37 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/9480/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+# Anthy can not compile with sandbox since version 5209.
+# It always causes SEGV at making mkanthydic.
+SANDBOX_DISABLED="1"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-uc4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.am
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.am
+ fi
+
+ autoconf
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5312 b/app-i18n/anthy-ss/files/digest-anthy-ss-5312
new file mode 100644
index 000000000000..edc3cbe768f8
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5312
@@ -0,0 +1 @@
+MD5 81065e1a92f34299607bf58ef24f51c7 anthy-5312.tar.gz 1545499