summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-21 08:55:01 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-21 08:55:01 +0000
commitebbfc80816d4d8b81f68fe693ec506f767161a50 (patch)
tree3683c137913815f256710c76e8390cc4eeb10eaf /app-gnustep/pantomime
parentNew ebuild. Finally a stable release. :) (diff)
downloadhistorical-ebbfc80816d4d8b81f68fe693ec506f767161a50.tar.gz
historical-ebbfc80816d4d8b81f68fe693ec506f767161a50.tar.bz2
historical-ebbfc80816d4d8b81f68fe693ec506f767161a50.zip
added ssl portion based on suggestion on bug #26961
Diffstat (limited to 'app-gnustep/pantomime')
-rw-r--r--app-gnustep/pantomime/Manifest2
-rw-r--r--app-gnustep/pantomime/pantomime-1.1.0.ebuild24
2 files changed, 24 insertions, 2 deletions
diff --git a/app-gnustep/pantomime/Manifest b/app-gnustep/pantomime/Manifest
index 32688bbfbfb4..d2cbf4b1f30b 100644
--- a/app-gnustep/pantomime/Manifest
+++ b/app-gnustep/pantomime/Manifest
@@ -1,4 +1,4 @@
-MD5 e50850a5cc7d203607abf49f04a9f9a9 pantomime-1.1.0.ebuild 556
+MD5 65989f0a2b9665d52cb4060bdebc671b pantomime-1.1.0.ebuild 907
MD5 5883b073b56f6f14338ed3c32432a55b pantomime-1.1.0_pre2.ebuild 611
MD5 783a6d9a5a3869f194c0fb2aa06a512a ChangeLog 745
MD5 80699754a7e9adb6c02df33c8fa16fd6 metadata.xml 161
diff --git a/app-gnustep/pantomime/pantomime-1.1.0.ebuild b/app-gnustep/pantomime/pantomime-1.1.0.ebuild
index bb6a7491d743..cda8da663e97 100644
--- a/app-gnustep/pantomime/pantomime-1.1.0.ebuild
+++ b/app-gnustep/pantomime/pantomime-1.1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-gnustep/pantomime/pantomime-1.1.0.ebuild,v 1.1 2003/08/21 08:43:27 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-gnustep/pantomime/pantomime-1.1.0.ebuild,v 1.2 2003/08/21 08:54:56 g2boojum Exp $
+
+IUSE="ssl"
inherit base gnustep
@@ -11,3 +13,23 @@ SRC_URI="http://www.collaboration-world.com/pantomime.data/releases/Stable/${PN/
KEYWORDS="~x86 ~ppc"
SLOT="0"
S=${WORKDIR}/${PN/p/P}
+
+src_compile() {
+ egnustepmake
+ if [ "`use ssl`" ]; then
+ cd ${S}/Bundles/SSL
+ make
+ cd ${S}
+ fi
+}
+
+src_install() {
+ egnustepinstall
+
+ if [ "`use ssl`" ]; then
+ mkdir -p ${D}usr/GNUstep/System/Library/Pantomime
+ cd ${S}/Bundles/SSL
+ tar cf - TCPSSLConnection.bundle | ( cd ${D}usr/GNUstep/System/Library/Pantomime; tar xf - )
+ fi
+}
+