summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-24 05:24:04 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-24 05:24:04 +0000
commitd4aaf5e47e72500c5a74eb4a76f45e3405c2d5f8 (patch)
treec8576fc7d6f942f979a330474637dd93b1ffec7a /app-emulation
parentremove zlib support (diff)
downloadhistorical-d4aaf5e47e72500c5a74eb4a76f45e3405c2d5f8.tar.gz
historical-d4aaf5e47e72500c5a74eb4a76f45e3405c2d5f8.tar.bz2
historical-d4aaf5e47e72500c5a74eb4a76f45e3405c2d5f8.zip
X11 support and opengl support added by Per Wigren. Fixes #4047
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/snes9x/ChangeLog9
-rw-r--r--app-emulation/snes9x/files/digest-snes9x-139-r11
-rw-r--r--app-emulation/snes9x/snes9x-139-r1.ebuild29
3 files changed, 38 insertions, 1 deletions
diff --git a/app-emulation/snes9x/ChangeLog b/app-emulation/snes9x/ChangeLog
index 4e3fdc46de28..962cb344bbd0 100644
--- a/app-emulation/snes9x/ChangeLog
+++ b/app-emulation/snes9x/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/snes9x
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.1 2002/05/27 02:03:52 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.2 2002/06/24 05:24:04 rphillips Exp $
+
+*snes-139-r1 (23 Jun 2002)
+
+ 23 Jun 2002; Ryan Phillips <rphillips@gentoo.org> snes-139-r1.ebuild :
+
+ Thanks to Per Wigren the ebuild has been updated with X11 support and
+ opengl.
*snes-139 (26 May 2002)
diff --git a/app-emulation/snes9x/files/digest-snes9x-139-r1 b/app-emulation/snes9x/files/digest-snes9x-139-r1
new file mode 100644
index 000000000000..7436413f1239
--- /dev/null
+++ b/app-emulation/snes9x/files/digest-snes9x-139-r1
@@ -0,0 +1 @@
+MD5 eb8fb2cc365a9dcc18106a05bcdd3ac1 s9xs139.zip 666463
diff --git a/app-emulation/snes9x/snes9x-139-r1.ebuild b/app-emulation/snes9x/snes9x-139-r1.ebuild
new file mode 100644
index 000000000000..ab777f63a1af
--- /dev/null
+++ b/app-emulation/snes9x/snes9x-139-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Ryan Phillips <rphillips@gentoo.org>, Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.1 2002/06/24 05:24:04 rphillips Exp $
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="http://www.snes9x.com/"
+LICENSE="as-is"
+SRC_URI="http://www.snes9x.com/zips/s9xs${PV}.zip"
+DEPEND="dev-lang/nasm
+ virtual/x11
+ opengl? ( virtual/opengl )
+ glide? ( media-libs/glide-v3 )"
+
+S=${WORKDIR}/release
+
+src_compile() {
+ emake -f Makefile.linux || die
+ use opengl && ( emake -f Makefile.linux OPENGL=1 clean all || die )
+ use glide && ( emake -f Makefile.linux GLIDE=1 clean all || die )
+}
+
+src_install() {
+ dobin snes9x ssnes9x
+ use opengl && dobin osnes9x
+ use glide && dobin gsnes9x
+ dodoc COPYRIGHT.TXT CHANGES.TXT README.TXT PROBLEMS.TXT TODO.TXT HARDWARE.TXT
+}
+