summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-27 05:56:22 +0000
committerMike Frysinger <vapier@gentoo.org>2009-04-27 05:56:22 +0000
commitb532b1f05198209cd9e7aaed9bcc3e6cf3cd02ab (patch)
treea2194068c472b9c37a97e0407e9d7e5df9960ec5 /app-emulation
parentmasking dev-tcltk/tls-1.6 because of sandbox violations and qa issues, bug #2... (diff)
downloadhistorical-b532b1f05198209cd9e7aaed9bcc3e6cf3cd02ab.tar.gz
historical-b532b1f05198209cd9e7aaed9bcc3e6cf3cd02ab.tar.bz2
historical-b532b1f05198209cd9e7aaed9bcc3e6cf3cd02ab.zip
old
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-0.9.53.ebuild133
-rw-r--r--app-emulation/wine/wine-0.9.54.ebuild133
-rw-r--r--app-emulation/wine/wine-0.9.55.ebuild133
-rw-r--r--app-emulation/wine/wine-0.9.56.ebuild133
-rw-r--r--app-emulation/wine/wine-0.9.57.ebuild133
-rw-r--r--app-emulation/wine/wine-0.9.58.ebuild145
-rw-r--r--app-emulation/wine/wine-0.9.59.ebuild144
7 files changed, 0 insertions, 954 deletions
diff --git a/app-emulation/wine/wine-0.9.53.ebuild b/app-emulation/wine/wine-0.9.53.ebuild
deleted file mode 100644
index e8d66612093e..000000000000
--- a/app-emulation/wine/wine-0.9.53.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.53.ebuild,v 1.4 2008/04/04 23:34:31 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- >=media-gfx/fontforge-20060703
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- unpack wine-${PV}.tar.bz2
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}
diff --git a/app-emulation/wine/wine-0.9.54.ebuild b/app-emulation/wine/wine-0.9.54.ebuild
deleted file mode 100644
index 6d0ff25a4eea..000000000000
--- a/app-emulation/wine/wine-0.9.54.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.54.ebuild,v 1.4 2008/04/04 23:34:31 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- >=media-gfx/fontforge-20060703
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- unpack wine-${PV}.tar.bz2
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}
diff --git a/app-emulation/wine/wine-0.9.55.ebuild b/app-emulation/wine/wine-0.9.55.ebuild
deleted file mode 100644
index 39dbb0fdad5f..000000000000
--- a/app-emulation/wine/wine-0.9.55.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.55.ebuild,v 1.4 2008/04/04 23:34:31 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- >=media-gfx/fontforge-20060703
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- unpack wine-${PV}.tar.bz2
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}
diff --git a/app-emulation/wine/wine-0.9.56.ebuild b/app-emulation/wine/wine-0.9.56.ebuild
deleted file mode 100644
index 1f8e72772d44..000000000000
--- a/app-emulation/wine/wine-0.9.56.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.56.ebuild,v 1.4 2008/04/18 17:58:22 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- >=media-gfx/fontforge-20060703
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- unpack wine-${PV}.tar.bz2
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}
diff --git a/app-emulation/wine/wine-0.9.57.ebuild b/app-emulation/wine/wine-0.9.57.ebuild
deleted file mode 100644
index 793bbc517d0d..000000000000
--- a/app-emulation/wine/wine-0.9.57.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.57.ebuild,v 1.3 2008/04/18 17:58:22 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- >=media-gfx/fontforge-20060703
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- unpack wine-${PV}.tar.bz2
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}
diff --git a/app-emulation/wine/wine-0.9.58.ebuild b/app-emulation/wine/wine-0.9.58.ebuild
deleted file mode 100644
index 2043a4901348..000000000000
--- a/app-emulation/wine/wine-0.9.58.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.58.ebuild,v 1.4 2008/06/13 21:16:59 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
- inherit git
- SRC_URI=""
-else
- SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
-fi
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="${SRC_URI}
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- >=media-gfx/fontforge-20060703
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- else
- unpack wine-${PV}.tar.bz2
- fi
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog DEVELOPERS-HINTS README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}
diff --git a/app-emulation/wine/wine-0.9.59.ebuild b/app-emulation/wine/wine-0.9.59.ebuild
deleted file mode 100644
index 74ee01658c95..000000000000
--- a/app-emulation/wine/wine-0.9.59.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.59.ebuild,v 1.3 2008/06/13 21:16:59 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
- inherit git
- SRC_URI=""
-else
- SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
-fi
-
-DESCRIPTION="free implementation of Windows(tm) on Unix"
-HOMEPAGE="http://www.winehq.org/"
-SRC_URI="${SRC_URI}
- gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* amd64 x86 ~x86-fbsd"
-IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
-RESTRICT="test" #72375
-
-RDEPEND=">=media-libs/freetype-2.0.0
- media-fonts/corefonts
- ncurses? ( >=sys-libs/ncurses-5.2 )
- jack? ( media-sound/jack-audio-connection-kit )
- dbus? ( sys-apps/dbus )
- hal? ( sys-apps/hal )
- X? (
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- x11-apps/xmessage
- )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- jpeg? ( media-libs/jpeg )
- ldap? ( net-nds/openldap )
- lcms? ( media-libs/lcms )
- samba? ( >=net-fs/samba-3.0.25 )
- xml? ( dev-libs/libxml2 dev-libs/libxslt )
- scanner? ( media-gfx/sane-backends )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1
- >=sys-kernel/linux-headers-2.6
- )"
-DEPEND="${RDEPEND}
- X? (
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- use alsa || return 0
- if ! built_with_use --missing true media-libs/alsa-lib midi ; then
- eerror "You must build media-libs/alsa-lib with USE=midi"
- die "please re-emerge media-libs/alsa-lib with USE=midi"
- fi
-}
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- else
- unpack wine-${PV}.tar.bz2
- fi
- cd "${S}"
-
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
- epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
- sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-}
-
-config_cache() {
- local h ans="no"
- use $1 && ans="yes"
- shift
- for h in "$@" ; do
- [[ ${h} == *.h ]] \
- && h=header_${h} \
- || h=lib_${h}
- export ac_cv_${h//[:\/.]/_}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- use esd || export ac_cv_path_ESDCONFIG=""
- use scanner || export ac_cv_path_sane_devel="no"
- config_cache jack jack/jack.h
- config_cache cups cups/cups.h
- config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
- config_cache nas audio/audiolib.h audio/soundlib.h
- config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
- config_cache ldap ldap.h lber.h
- config_cache dbus dbus/dbus.h
- config_cache hal hal/libhal.h
- config_cache jpeg jpeglib.h
- config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
-
- strip-flags
-
- use amd64 && multilib_toolchain_setup x86
-
- # $(use_enable amd64 win64)
- econf \
- --sysconfdir=/etc/wine \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ANNOUNCE AUTHORS ChangeLog DEVELOPERS-HINTS README
- if use gecko ; then
- insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-*.cab || die
- fi
-}
-
-pkg_postinst() {
- elog "~/.wine/config is now deprecated. For configuration either use"
- elog "winecfg or regedit HKCU\\Software\\Wine"
-}