summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-05-12 21:58:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-05-12 21:58:37 +0000
commita805097a40343986ce5879e1bbc64279246d769a (patch)
tree8616452be5f3020923861df9a481deb10db7e128 /app-emulation
parentMoved spacetripper-demo and mutantstorm-demo (diff)
downloadhistorical-a805097a40343986ce5879e1bbc64279246d769a.tar.gz
historical-a805097a40343986ce5879e1bbc64279246d769a.tar.bz2
historical-a805097a40343986ce5879e1bbc64279246d769a.zip
2.6.6 makefile fix
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/ChangeLog7
-rw-r--r--app-emulation/mol/Manifest13
-rw-r--r--app-emulation/mol/files/mol-0.9.70-makefile-fix.patch20
-rw-r--r--app-emulation/mol/mol-0.9.70.ebuild4
4 files changed, 35 insertions, 9 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index a91d30c05d6f..93ffbaf42766 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.35 2004/03/21 23:01:54 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.36 2004/05/12 21:58:37 lu_zero Exp $
+
+ 12 May 2004; Luca Barbato <lu_zero@gentoo.org>
+ +files/mol-0.9.70-makefile-fix.patch, mol-0.9.70.ebuild:
+ Added a fix for 2.6.6 kernels, thanks to Benoit Chesneau
+ <benoitc@metavers.net> for pointing the Andreas Schwab <schwab@suse.de> patch.
*mol-0.9.70 (21 Mar 2004)
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index 90932712d4c4..67b2965ce8e7 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,9 +1,10 @@
-MD5 6db0245154eba2435cbca14466e6dc4b ChangeLog 7208
+MD5 1523ac09dfccc8690eb7de489a1da311 mol-0.9.70_rc2-r1.ebuild 3736
+MD5 cdf52804f26a0e55aaf0d7dca53ccbac ChangeLog 7458
MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
-MD5 d94a2198277e731eb998ec4aa4c432d1 mol-0.9.68-r4.ebuild 2219
-MD5 f87f5c7f5d0221fc25a2a2b5c1428d60 mol-0.9.70.ebuild 3708
-MD5 d26cba4dca57d4c19421569fff151895 mol-0.9.70_rc2-r1.ebuild 3737
-MD5 d4bc3f0122eb77fbfbfcf584f442049d files/digest-mol-0.9.68-r4 67
-MD5 3944510308e77b92ac85c07708947ad0 files/digest-mol-0.9.70 64
+MD5 5995501009f07926342b19cd5932ad0d mol-0.9.68-r4.ebuild 2218
+MD5 c92871c3f7e33e96a4a634e167573bed mol-0.9.70.ebuild 3752
MD5 98990df6bb9f196021dea0b77d2d912d files/26-arch-fix.patch 2320
MD5 9250d5f1a7e9cbe52e9e3621d14294c8 files/digest-mol-0.9.70_rc2-r1 71
+MD5 3944510308e77b92ac85c07708947ad0 files/digest-mol-0.9.70 64
+MD5 d4bc3f0122eb77fbfbfcf584f442049d files/digest-mol-0.9.68-r4 67
+MD5 0ea7bd65a5ff4666665a71fb9652aae8 files/mol-0.9.70-makefile-fix.patch 924
diff --git a/app-emulation/mol/files/mol-0.9.70-makefile-fix.patch b/app-emulation/mol/files/mol-0.9.70-makefile-fix.patch
new file mode 100644
index 000000000000..0ec3c9e0f892
--- /dev/null
+++ b/app-emulation/mol/files/mol-0.9.70-makefile-fix.patch
@@ -0,0 +1,20 @@
+--- src/kmod/Linux/Makefile.26-orig 2004-05-12 16:53:54.412715816 +0200
++++ src/kmod/Linux/Makefile.26 2004-05-12 16:56:08.325358000 +0200
+@@ -9,7 +9,7 @@
+ obj-m := _kuname.o mol.o
+
+ PERFOBJS = $(addprefix $(obj)/, $(PERFOBJS_))
+-MOL_ASMFLAGS = $(ASMFLAGS) $(INCLUDES) -D__ASSEMBLY__
++MOL_ASMFLAGS = $(CPPFLAGS) $(ASMFLAGS) $(INCLUDES) -D__ASSEMBLY__
+
+
+ $(obj)/hook.o: $(src)/reloc_table.h
+@@ -37,7 +37,7 @@
+ $(src)/asm_offsets.h: $(src)/archinclude.h $(src)/kernel_vars.h $(src)/mac_registers.h
+ $(src)/asm_offsets.h: $(src)/asm_offsets.c $(src)/asm_offsets.inc
+ @$(RM) $(src)/tmp-offsets.c $@ ; cat $^ > $(src)/tmp-offsets.c
+- @$(CC) $(CFLAGS) -I$(src) -Wall -S $(src)/tmp-offsets.c
++ @$(CC) $(CPPFLAGS) $(CFLAGS) -I$(src) -Wall -S $(src)/tmp-offsets.c
+ @echo "/* WARNING! Automatically generated from 'shared/asm_offsets.c' - DO NOT EDIT! */" > $@
+ @grep '^#' tmp-offsets.s >> $@
+ @$(RM) $(src)/tmp-offsets.*
diff --git a/app-emulation/mol/mol-0.9.70.ebuild b/app-emulation/mol/mol-0.9.70.ebuild
index 1a1a6cf2f076..a331a3a0e673 100644
--- a/app-emulation/mol/mol-0.9.70.ebuild
+++ b/app-emulation/mol/mol-0.9.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.2 2004/03/22 01:39:51 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.3 2004/05/12 21:58:37 lu_zero Exp $
inherit flag-o-matic
@@ -36,7 +36,7 @@ src_unpack() {
sed -i "s:prefix = /usr/local:prefix = /usr:" Makefile.top || die
sed -i "s#VENDOR :=#VENDOR := -gentoo#" Makefile.top || die
-
+ epatch ${FILESDIR}/${P}-makefile-fix.patch
}
src_compile() {