summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-02-04 07:05:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-02-04 07:05:49 +0000
commit91daf13a6fea8ca6acfdff5f6f243c51b1fd62d7 (patch)
tree42837ffccdc5fc80e5d5496171915aed5c7fc784 /app-emulation
parentRemove old version (diff)
downloadhistorical-91daf13a6fea8ca6acfdff5f6f243c51b1fd62d7.tar.gz
historical-91daf13a6fea8ca6acfdff5f6f243c51b1fd62d7.tar.bz2
historical-91daf13a6fea8ca6acfdff5f6f243c51b1fd62d7.zip
fix virt-pki-validate. clean up some elog/ewarn messages
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog9
-rw-r--r--app-emulation/libvirt/files/libvirt-0.7.6-virt-pki-validate-sysconfdir.patch27
-rw-r--r--app-emulation/libvirt/libvirt-0.7.6-r1.ebuild (renamed from app-emulation/libvirt/libvirt-0.7.6.ebuild)25
3 files changed, 51 insertions, 10 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index a237f6e946aa..bfd3c24c4f34 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.48 2010/02/03 19:57:01 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.49 2010/02/04 07:05:48 cardoe Exp $
+
+*libvirt-0.7.6-r1 (04 Feb 2010)
+
+ 04 Feb 2010; Doug Goldstein <cardoe@gentoo.org> -libvirt-0.7.6.ebuild,
+ +libvirt-0.7.6-r1.ebuild,
+ +files/libvirt-0.7.6-virt-pki-validate-sysconfdir.patch:
+ fix virt-pki-validate. clean up some elog/ewarn messages
*libvirt-0.7.6 (03 Feb 2010)
diff --git a/app-emulation/libvirt/files/libvirt-0.7.6-virt-pki-validate-sysconfdir.patch b/app-emulation/libvirt/files/libvirt-0.7.6-virt-pki-validate-sysconfdir.patch
new file mode 100644
index 000000000000..85b7276356db
--- /dev/null
+++ b/app-emulation/libvirt/files/libvirt-0.7.6-virt-pki-validate-sysconfdir.patch
@@ -0,0 +1,27 @@
+From 6323f5f4c056c84d3beaee1f1057ade437cf1e8f Mon Sep 17 00:00:00 2001
+From: Doug Goldstein <cardoe@gentoo.org>
+Date: Thu, 4 Feb 2010 00:37:42 -0600
+Subject: [PATCH] virt-pki-validate contains unexpanded SYSCONFDIR variable
+
+virt-pki-validate contains an unexpanded SYSCONFDIR variable which
+causes it not to function at all.
+---
+ tools/virt-pki-validate.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tools/virt-pki-validate.in b/tools/virt-pki-validate.in
+index a428a96..3e8c642 100755
+--- a/tools/virt-pki-validate.in
++++ b/tools/virt-pki-validate.in
+@@ -25,7 +25,7 @@ echo Found $CERTOOL
+ #
+ # Check the directory structure
+ #
+-PKI="$(SYSCONFDIR)/pki"
++PKI="@SYSCONFDIR@/pki"
+ if [ ! -d $PKI ]
+ then
+ echo the $PKI directory is missing, it is usually
+--
+1.6.6.1
+
diff --git a/app-emulation/libvirt/libvirt-0.7.6.ebuild b/app-emulation/libvirt/libvirt-0.7.6-r1.ebuild
index 00c4906df3be..b5c81a821aa8 100644
--- a/app-emulation/libvirt/libvirt-0.7.6.ebuild
+++ b/app-emulation/libvirt/libvirt-0.7.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.7.6.ebuild,v 1.1 2010/02/03 19:57:01 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.7.6-r1.ebuild,v 1.1 2010/02/04 07:05:48 cardoe Exp $
BACKPORTS=
@@ -57,6 +57,8 @@ DEPEND="${RDEPEND}
src_prepare() {
[[ -n ${BACKPORTS} ]] && \
EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" epatch
+
+ epatch "${FILESDIR}"/${P}-virt-pki-validate-sysconfdir.patch
}
src_configure() {
@@ -155,9 +157,12 @@ pkg_preinst() {
pkg_postinst() {
use python && python_mod_optimize $(python_get_sitedir)/libvirt.py
+ elog
if use policykit; then
- elog "You must have run the following at least once"
- elog "polkit-auth --grant org.libvirt.unix.manage --user \"USERNAME\""
+ elog "You must have run the following at least once:"
+ elog
+ elog "$ polkit-auth --grant org.libvirt.unix.manage --user \"USERNAME\""
+ elog
elog "to grant USERNAME access to libvirt when using USE=policykit"
else
elog "To allow normal users to connect to libvirtd you must change the"
@@ -173,12 +178,14 @@ pkg_postinst() {
elog " net-firewall/iptables"
elog " net-firewall/ebtables"
elog
- ewarn "If you have a DNS server setup on your machine, you will have"
- ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
- ewarn " bind-interfaces"
- ewarn " interface or except-interface"
- elog
- ewarn "Otherwise you might have issues with your existing DNS server."
+ if has_version net-dns/dnsmasq; then
+ ewarn "If you have a DNS server setup on your machine, you will have"
+ ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
+ ewarn " bind-interfaces"
+ ewarn " interface or except-interface"
+ ewarn
+ ewarn "Otherwise you might have issues with your existing DNS server."
+ fi
}
pkg_postrm() {