summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-27 08:35:15 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-27 08:35:15 +0000
commit793fdcca185b0ef70353a0deaae88c827c85736e (patch)
treedd77141860c926e9da820f32d0e22995b108896f /app-emulation
parentPatch file... Forgot to commit (diff)
downloadhistorical-793fdcca185b0ef70353a0deaae88c827c85736e.tar.gz
historical-793fdcca185b0ef70353a0deaae88c827c85736e.tar.bz2
historical-793fdcca185b0ef70353a0deaae88c827c85736e.zip
Update package. Fixes #2958
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xmame/ChangeLog8
-rw-r--r--app-emulation/xmame/files/digest-xmame-0.60.11
-rw-r--r--app-emulation/xmame/xmame-0.60.1.ebuild61
3 files changed, 69 insertions, 1 deletions
diff --git a/app-emulation/xmame/ChangeLog b/app-emulation/xmame/ChangeLog
index 4aec5d3b9efd..573643a44fcb 100644
--- a/app-emulation/xmame/ChangeLog
+++ b/app-emulation/xmame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-games/xmame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.2 2002/03/28 06:50:41 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.3 2002/05/27 08:35:15 rphillips Exp $
+
+*xmame-0.60.1 (27 May 2002)
+
+ 27 May 2002; Ryan Phillips <rphillips@gentoo.org> xmame-0.60.1.ebuild :
+
+ Updated version and fixes to the xmame symlink. #2958
*xmame-0.59.1 (28 Mar 2002)
diff --git a/app-emulation/xmame/files/digest-xmame-0.60.1 b/app-emulation/xmame/files/digest-xmame-0.60.1
new file mode 100644
index 000000000000..b49b7ae7cf33
--- /dev/null
+++ b/app-emulation/xmame/files/digest-xmame-0.60.1
@@ -0,0 +1 @@
+MD5 887e3956e410b06b92165637ba219070 xmame-0.60.1.tar.bz2 5569579
diff --git a/app-emulation/xmame/xmame-0.60.1.ebuild b/app-emulation/xmame/xmame-0.60.1.ebuild
new file mode 100644
index 000000000000..6c313aba0a8c
--- /dev/null
+++ b/app-emulation/xmame/xmame-0.60.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jimmo Petisme <jimmobar@comp.nus.edu.sg>
+# Based on the 0.59.1 ebuild by Ben Lutgens <blutgens@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.60.1.ebuild,v 1.1 2002/05/27 08:35:15 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+SRC_URI="http://x.mame.net/download/${P}.tar.bz2"
+HOMEPAGE="http://x.mame.net"
+
+DEPEND="virtual/x11
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ >=sys-libs/zlib-1.1.3-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:CFLAGS = -O -Wall:\#CFLAGS=:g" -e \
+ "s:PREFIX = /usr/local:PREFIX = /usr:g" -e \
+ "s:MANDIR = \$\(PREFIX\)/man/man6:MANDIR = \$\(PREFIX\)/share/man/man6:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+
+ # Enable joystick support
+ sed -e "s/\# JOY_I386/JOY_I386/g" makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+
+ if [ "`use sdl`" ]; then
+ sed -e "s:DISPLAY_METHOD = x11:DISPLAY_METHOD = SDL:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+ fi
+
+ if [ "`use esd`" ]; then
+ sed -e "s/\# SOUND_ESOUND/SOUND_ESOUND/g" makefile.unix > Makefile
+ else
+ mv makefile.unix Makefile
+ fi
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+
+ make PREFIX=${D}/usr install
+
+# dodoc gzips
+ dodoc doc/{changes.*,dga2.txt,gamelist.mame,readme.mame,xmamerc.dist}
+ dodoc doc/{xmame-doc.ps,xmame-doc.txt}
+# Don't really want html files gzipped
+ insinto /usr/share/doc/${P}/html
+ doins doc/*.html
+ if [ "`use sdl`" ]; then
+ dosym xmame.SDL /usr/bin/xmame
+ else
+ dosym xmame.x11 /usr/bin/xmame
+ fi
+}