summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2003-06-24 11:55:41 +0000
committerHanno Boeck <hanno@gentoo.org>2003-06-24 11:55:41 +0000
commit62d2ea32a0123411bf6bfd777cb88270e78b00bc (patch)
tree336213e3d8d906464930951b81c9789d46f1f7cc /app-emulation
parentbump and cleanup (diff)
downloadhistorical-62d2ea32a0123411bf6bfd777cb88270e78b00bc.tar.gz
historical-62d2ea32a0123411bf6bfd777cb88270e78b00bc.tar.bz2
historical-62d2ea32a0123411bf6bfd777cb88270e78b00bc.zip
vice-1.12 version bump
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vice/ChangeLog7
-rw-r--r--app-emulation/vice/Manifest4
-rw-r--r--app-emulation/vice/files/digest-vice-1.121
-rw-r--r--app-emulation/vice/vice-1.12.ebuild50
4 files changed, 60 insertions, 2 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index f07ac4ef9054..ff078d62c24d 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vice
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.4 2003/03/23 07:48:49 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.5 2003/06/24 11:55:34 hanno Exp $
+
+*vice-1.12 (24 Jun 2003)
+
+ 24 Jun 2003; Hanno Boeck <hanno@gentoo.org> vice-1.12.ebuild:
+ Version bump.
*vice-1.11 (23 Mar 2003)
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 96a6645e121e..751d418a0294 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,3 +1,5 @@
-MD5 bd13d1168de93913cf12747dad771464 ChangeLog 656
+MD5 385fbfc77c3a5814770f9b5abd28c171 ChangeLog 763
+MD5 9493796d7927b933662bc68637fb1c7e vice-1.12.ebuild 1324
MD5 9e902858f9beeebb848e11f1f9eaa63b vice-1.11.ebuild 1323
+MD5 6b44b25bb31dd21195c5bb6ac016d49d files/digest-vice-1.12 62
MD5 a5dd12faf8edd8012553753de04c0a2d files/digest-vice-1.11 62
diff --git a/app-emulation/vice/files/digest-vice-1.12 b/app-emulation/vice/files/digest-vice-1.12
new file mode 100644
index 000000000000..b430d353eeda
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.12
@@ -0,0 +1 @@
+MD5 2d761503025a84758b289564e390c7c8 vice-1.12.tar.gz 3537855
diff --git a/app-emulation/vice/vice-1.12.ebuild b/app-emulation/vice/vice-1.12.ebuild
new file mode 100644
index 000000000000..959b3a14c18d
--- /dev/null
+++ b/app-emulation/vice/vice-1.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.12.ebuild,v 1.1 2003/06/24 11:55:34 hanno Exp $
+
+IUSE="sdl nls gnome"
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://viceteam.bei.t-online.de/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-base/xfree-4.0
+ sdl? ( media-libs/libsdl )
+ gnome? ( gnome-base/libgnomeui )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--enable-fullscreen"
+ use sdl && myconf="${myconf} --with-sdl"
+ use gnome && myconf="${myconf} --enable-gnomeui"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dohtml ${D}/usr/lib/vice/doc/*.html
+ dodoc \
+ ${D}/usr/lib/vice/doc/NLS-Howto.txt \
+ ${D}/usr/lib/vice/doc/Readme.beos \
+ ${D}/usr/lib/vice/doc/Readme.dos \
+ ${D}/usr/lib/vice/doc/Win32-Howto.txt \
+ ${D}/usr/lib/vice/doc/mon.txt
+
+ rm ${D}/usr/lib/vice/doc -rf
+}