summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 00:47:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 00:47:39 +0000
commit474804e39f661b70cf58c79b3296f5570d27a83e (patch)
tree3c207737fffffe8db5aa74c7b06ae87370dfc8ff /app-emulation
parentMPlayer, I'd like you to meet your new friend -falign-functions! *-falign-fu... (diff)
downloadhistorical-474804e39f661b70cf58c79b3296f5570d27a83e.tar.gz
historical-474804e39f661b70cf58c79b3296f5570d27a83e.tar.bz2
historical-474804e39f661b70cf58c79b3296f5570d27a83e.zip
loader doesnt use libc so we cant use strlen() #69215 by Marien Zwart.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/Manifest8
-rw-r--r--app-emulation/wine/files/20041019-load-wrappers.patch6
2 files changed, 6 insertions, 8 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 8b7659fd4a3b..3948a6793cb0 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -6,7 +6,7 @@ MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 4d56a684f6d2b0b0056c7b3fab3603dc wine-20041019-r1.ebuild 3556
MD5 56b0990c71158a55583c149383d8b652 wine-20041019.ebuild 3753
MD5 0b8a40b373bf8ab6c0368dd5a64f5449 wine-20040716.ebuild 3443
-MD5 f619ca99f68a2d81076b45b3c19ddbc5 files/20041019-load-wrappers.patch 1402
+MD5 9dbf73d557110996f187b6ed6ae4f7ea files/20041019-load-wrappers.patch 1333
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
MD5 ae28341f05c0916661c1346a28720230 files/QueryActCtxw_Photoshop7.0.diff 686
MD5 90d546d818e0470698ca6b743abe9fca files/digest-wine-20041019-r1 212
@@ -16,7 +16,7 @@ MD5 db29ae371718f3db0a915e65dc76f6f2 files/20041019-no-stack.patch 286
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBgEz1HTu7gpaalycRAgsKAJ9XOOn0+7vsaRFSVEgg5B6ZWjeswgCdEiAr
-4DCyR61T/LGfLSyhR0e3zq0=
-=SR0B
+iD8DBQFBhDZVHTu7gpaalycRApOPAJ9s8yRXmBEb32vp4t6G3fZ+g4Xt6wCgz6oD
+h8UVByueWyCy99irzSuVpfs=
+=lfWa
-----END PGP SIGNATURE-----
diff --git a/app-emulation/wine/files/20041019-load-wrappers.patch b/app-emulation/wine/files/20041019-load-wrappers.patch
index 35a54a797749..221dac7f1c0a 100644
--- a/app-emulation/wine/files/20041019-load-wrappers.patch
+++ b/app-emulation/wine/files/20041019-load-wrappers.patch
@@ -16,7 +16,7 @@
/* Scan the program header table, collecting its load commands. */
struct loadcmd
{
-@@ -503,9 +505,23 @@
+@@ -503,9 +505,21 @@
int prot;
} loadcmds[16], *c;
size_t nloadcmds = 0, maplength;
@@ -24,9 +24,7 @@
- fd = wld_open( name, O_RDONLY );
- if (fd == -1) fatal_error("%s: could not open\n", name );
-+ if (strlen(name)+5 >= MAXPATHLEN)
-+ fatal_error("%s: path too long\n", name);
-+ for (i=0; i<strlen(name); ++i)
++ for (i=0; (i<MAXPATHLEN-5) && (name[i]!='\0'); ++i)
+ altname[i] = name[i];
+ altname[i++] = '-';
+ altname[i++] = 'b';