summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-04-15 07:18:33 +0000
committerStefan Jones <cretin@gentoo.org>2003-04-15 07:18:33 +0000
commit44969ba9b69c1b41473057596eb5d47dfa502551 (patch)
tree736df924584537332dec003f57114c583ffa0931 /app-emulation
parentInitial commit. Ebuild submitted by Qubax, plus a few fixes. (diff)
downloadhistorical-44969ba9b69c1b41473057596eb5d47dfa502551.tar.gz
historical-44969ba9b69c1b41473057596eb5d47dfa502551.tar.bz2
historical-44969ba9b69c1b41473057596eb5d47dfa502551.zip
allow some CFLAGS
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog5
-rw-r--r--app-emulation/wine/wine-20030411.ebuild9
2 files changed, 8 insertions, 6 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 81a3c5b57449..9b60c13d4e7b 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.37 2003/04/12 17:30:35 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.38 2003/04/15 07:18:33 cretin Exp $
*wine-20020411 (11 Apr 2003)
+ 15 Apr 2002; Stefan Jones <cretin@gentoo.org> wine-20020411.ebuild :
+ use strip-flags and remove unset CFLAGS CXXFLAGS
+
12 Apr 2002; Tilman Klar <phoenix@gentoo.org> wine-20020411.ebuild :
Tagged this version stable ("x86"). Added support for USE="nptl".
diff --git a/app-emulation/wine/wine-20030411.ebuild b/app-emulation/wine/wine-20030411.ebuild
index 0d20711166a4..13a9ebd50740 100644
--- a/app-emulation/wine/wine-20030411.ebuild
+++ b/app-emulation/wine/wine-20030411.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030411.ebuild,v 1.3 2003/04/12 17:30:35 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030411.ebuild,v 1.4 2003/04/15 07:18:33 cretin Exp $
-inherit eutils base
+inherit eutils base flag-o-matic
DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
SRC_URI="mirror://gentoo/wine-${PV}.tar.bz2"
@@ -26,6 +26,8 @@ DEPEND="sys-devel/gcc
cups? ( net-print/cups )
opengl? ( virtual/opengl )"
+strip-flags
+
src_unpack() {
base_src_unpack
cd ${S}
@@ -42,9 +44,6 @@ src_compile() {
[ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
# there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
- # use the default setting in ./configure over the /etc/make.conf setting
- unset CFLAGS CXXFLAGS
-
./configure --prefix=/usr/lib/wine \
--sysconfdir=/etc/wine \
--host=${CHOST} \