summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-06-07 00:54:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-06-07 00:54:51 +0000
commit361eed74ab9d73d606246a4df47f0d8ae6e66df3 (patch)
tree71aa1455afb4947175f2ec6ed996a60b6d5a9082 /app-emulation
parentInitial version. Thanks to Thomas Phipps and A.Sleep. Closes #11879 (diff)
downloadhistorical-361eed74ab9d73d606246a4df47f0d8ae6e66df3.tar.gz
historical-361eed74ab9d73d606246a4df47f0d8ae6e66df3.tar.bz2
historical-361eed74ab9d73d606246a4df47f0d8ae6e66df3.zip
use sed -i and use_with
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/Manifest4
-rw-r--r--app-emulation/bochs/bochs-2.0.2.ebuild27
3 files changed, 17 insertions, 19 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index f1757a559b34..656d4f9460ae 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.8 2003/02/12 03:59:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.9 2003/06/07 00:54:47 msterret Exp $
+
+ 06 Jun 2003; <msterret@gentoo.org> bochs-2.0.2.ebuild:
+ use sed -i and use_with
*bochs-2.0 (07 Feb 2003)
07 Feb 2003; Luca Barbato <lu_zero@gentoo.org> ChangeLog : bochs-2.0.2.ebuild
diff --git a/app-emulation/bochs/Manifest b/app-emulation/bochs/Manifest
index 9721e355f12c..ece955b8ad73 100644
--- a/app-emulation/bochs/Manifest
+++ b/app-emulation/bochs/Manifest
@@ -1,7 +1,7 @@
-MD5 94dfd434cdfdc97d7eb34ec255c9e015 ChangeLog 1047
+MD5 c69f84b40c2d58d66eb5830007ceba98 ChangeLog 1133
MD5 3fc3de44c4d8ea336e2e8c3e65984593 bochs-1.4.1.ebuild 1589
MD5 887420e60dbb71b6c6736f5e170e4484 bochs-1.4.ebuild 1519
-MD5 b2699d94a449a59db7617e7d3524e189 bochs-2.0.2.ebuild 1607
+MD5 861e974ed57fbcdded4a906d90ecf520 bochs-2.0.2.ebuild 1542
MD5 a915a1253cdf70325ddf3b7f3df03953 bochs-2.0.ebuild 1495
MD5 98e5b3f35a6f0ad02450764b07b344f6 files/digest-bochs-1.4 124
MD5 45eecf87d56bd4562cffd0c8cfe666f9 files/digest-bochs-1.4.1 126
diff --git a/app-emulation/bochs/bochs-2.0.2.ebuild b/app-emulation/bochs/bochs-2.0.2.ebuild
index 5b4f9e692e20..57d50a205901 100644
--- a/app-emulation/bochs/bochs-2.0.2.ebuild
+++ b/app-emulation/bochs/bochs-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.2 2003/02/13 07:12:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.3 2003/06/07 00:54:47 msterret Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Bochs is a pc emulator.
@@ -15,6 +15,7 @@ IUSE="sdl gtk"
DEPEND=">=sys-libs/glibc-2.1.3
>=x11-base/xfree-4.0.1
+ >=sys-apps/sed-4
sdl? media-libs/libsdl
gtk? x11-libs/wxGTK
"
@@ -23,34 +24,28 @@ KEYWORDS="~x86 ~ppc"
src_unpack() {
unpack ${P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
-e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' ${S}/Makefile.in || \
+ die "sed Makefile.in failed"
}
src_compile() {
-
[ "$ARCH" == "x86" ] && myconf="--enable-idle-hack"
- use sdl && myconf="${myconf} --with-sdl" \
- || myconf="${myconf} --without-sdl"
- use gtk && myconf="${myconf} --with-wx" \
- || myconf="${myconf} --without-wx"
-
+ myconf="${myconf} `use_with sdl`"
+ myconf="${myconf} `use_with gtk wx`"
+
./configure --enable-fpu --enable-cdrom --enable-control-panel \
--enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
- --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} --with-x11 $myconf || die
-
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} \
+ --with-x11 $myconf || die "configure failed"
emake || die
}
-
src_install () {
-
make DESTDIR=${D} install || die
dodoc CHANGES COPYING CVS README TESTFORM.txt
}
-