summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-07 15:50:34 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-07 15:50:34 +0000
commit1e68fc90bb2e954f88ff04e6befd738bd063a3fe (patch)
treeac0d9bd2b19867119919c8f75684492d83ccc6a5 /app-emulation
parentAdded ~mips keyword. (diff)
downloadhistorical-1e68fc90bb2e954f88ff04e6befd738bd063a3fe.tar.gz
historical-1e68fc90bb2e954f88ff04e6befd738bd063a3fe.tar.bz2
historical-1e68fc90bb2e954f88ff04e6befd738bd063a3fe.zip
Replace -O3 with -O2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uae/ChangeLog5
-rw-r--r--app-emulation/uae/Manifest4
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild5
3 files changed, 10 insertions, 4 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index fa7fd3604c08..9c85862b1e69 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.15 2004/03/05 13:29:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.16 2004/03/07 15:50:34 dholm Exp $
+
+ 07 Mar 2004; David Holm <dholm@gentoo.org> uae-0.8.25_pre20040302.ebuild:
+ Replace -O3 with -O2 (again). Splitting cpuemu_6.c was not enough.
05 Mar 2004; David Holm <dholm@gentoo.org> uae-0.8.25_pre20040302.ebuild,
files/split_cpuemu.pl:
diff --git a/app-emulation/uae/Manifest b/app-emulation/uae/Manifest
index 2f4b8eb93f55..9049203cd8dd 100644
--- a/app-emulation/uae/Manifest
+++ b/app-emulation/uae/Manifest
@@ -1,8 +1,8 @@
-MD5 73fefc76e7aa030a2c0c93b69571de2a ChangeLog 2538
+MD5 fb123318e85818f77d1bb32f88e77f32 ChangeLog 2684
MD5 9942fdc6d0c4e617f237b18ed3f71768 uae-0.8.22.ebuild 1251
MD5 800d59bca6b74f54268ca8c63af928ee metadata.xml 668
MD5 a79fb678ea1d364d3105b6fbc3ddacc4 uae-0.8.23_pre20040129.ebuild 1348
-MD5 bcfcafc2f832275ae56f4693c4945e25 uae-0.8.25_pre20040302.ebuild 1615
+MD5 356dbebd21aa5a3fb24c84fb85e7df9c uae-0.8.25_pre20040302.ebuild 1732
MD5 77b204c71d52f0a0423054b5a9b8a0cb files/split_cpuemu.pl 498
MD5 b2fac0f21ee34abaa6279cf7ad023119 files/digest-uae-0.8.22 62
MD5 4d3af2d2cc2945b006249066cb8c7adb files/uae-patch.diff 364
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
index a9c99d568716..899f17503f6f 100644
--- a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.3 2004/03/05 13:29:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.4 2004/03/07 15:50:34 dholm Exp $
+
+inherit flag-o-matic
MY_PV="0.8.25-20040302"
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -20,6 +22,7 @@ DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
games-emulation/caps"
src_compile() {
+ replace-flags "-O3" "-O2"
use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
cp ${FILESDIR}/split_cpuemu.pl ${S}/src