summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-02-07 22:05:24 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-02-07 22:05:24 +0000
commit13138988f4f1a888fb8bfc5de62fd09bf8323de0 (patch)
tree8d88e3f26710de22c29ebcd4938b0e40ae3f5265 /app-emulation
parentfixes configure issue, and sandbox problem (diff)
downloadhistorical-13138988f4f1a888fb8bfc5de62fd09bf8323de0.tar.gz
historical-13138988f4f1a888fb8bfc5de62fd09bf8323de0.tar.bz2
historical-13138988f4f1a888fb8bfc5de62fd09bf8323de0.zip
new version. x86 masked
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dosemu/ChangeLog7
-rw-r--r--app-emulation/dosemu/dosemu-1.1.4.ebuild65
-rw-r--r--app-emulation/dosemu/files/digest-dosemu-1.1.42
3 files changed, 73 insertions, 1 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index d67acba3494d..bf900cb777dd 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/dosemu
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.6 2002/10/19 16:46:15 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.7 2003/02/07 22:05:24 rphillips Exp $
+
+*dosemu-1.1.4 (07 Feb 2003)
+
+ 07 Feb 2003; Ryan Phillips <rphillips@gentoo.org> dosemu-1.1.4.ebuild :
+ new version
*dosemu-1.1.3-r1 (27 Jul 2002)
diff --git a/app-emulation/dosemu/dosemu-1.1.4.ebuild b/app-emulation/dosemu/dosemu-1.1.4.ebuild
new file mode 100644
index 000000000000..d4f82588a59f
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.1.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.1.4.ebuild,v 1.1 2003/02/07 22:05:24 rphillips Exp $
+
+IUSE="X svga"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="DOS Emulator"
+SRC_URI="mirror://sourceforge/dosemu/${PN}-freedos-bin.tgz
+ mirror://sourceforge/dosemu/${P}.tgz"
+HOMEPAGE="http://www.dosemu.org/"
+LICENSE="GPL-2 | LGPL-2.1"
+KEYWORDS="~x86 -ppc"
+SLOT="0"
+DEPEND="X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+src_compile() {
+
+### We make base-configure executable here, so that we can pretend its our
+### ./configure script, by passing it cli arguments, we bypass the usual
+### DOSemu installation script routines :)
+
+ chmod +x base-configure
+
+ local myflags
+
+### mitshm will bork ./base-configure entirely, so we disable it here
+ myflags="--enable-mitshm=no"
+ myflags="${myflags} --enable-experimental"
+
+### and then set build paramaters based on USE variables
+ use X || myflags="${myflags} --with-x=no"
+ use svga && myflags="${myflags} --enable-use-svgalib"
+
+### this is really a ./configure (honestly)
+ ./base-configure \
+ ${myflags} || die "DOSemu Base Configuration Failed"
+
+### We HAVE to do this, or the build will fail due to strange additional
+### files in the downloaded tarball!
+ emake pristine || die "Dosemu Make Pristine Failed"
+
+### Ok, the build tree is clean, lets make the executables, and 'dos' commands
+ emake -C src || die "DOSemu Make Failed!"
+ emake dosbin || die "DOSbin Make Failed"
+}
+
+src_install () {
+
+### There is no 'make install' for DOSemu, just a set of install scripts
+### We'll pass our portage image directory as the fs root, and 'install'
+### as normal, this seems to stick with the usual gentoo standards
+
+ ./install_systemwide -fd ${DISTDIR}/dosemu-freedos-bin.tgz -r ${D}
+
+### install_systemwide doesn't pay attention to our man/info locations
+### we'll install them to the correct location with doman now that they've
+### been created and remove them from the new source tree before emerge
+### installs everything to our 'real' filesystem
+
+ doman man/*.1
+ rm -rf ${D}/opt/dosemu/man/
+
+}
+
diff --git a/app-emulation/dosemu/files/digest-dosemu-1.1.4 b/app-emulation/dosemu/files/digest-dosemu-1.1.4
new file mode 100644
index 000000000000..2dff4ea78818
--- /dev/null
+++ b/app-emulation/dosemu/files/digest-dosemu-1.1.4
@@ -0,0 +1,2 @@
+MD5 ba5004378e6cacb1f7e5f9155f1ef176 dosemu-freedos-bin.tgz 686855
+MD5 be632c6e5edd3388d9d6d2c8dba7dc10 dosemu-1.1.4.tgz 2200531