summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2005-12-08 12:55:33 +0000
committerChris Bainbridge <chrb@gentoo.org>2005-12-08 12:55:33 +0000
commit0ace72852c1b6f5a955f4286768c248bb9723a5d (patch)
tree823003bbb02d8c1226954f69db930c01598358b1 /app-emulation
parentadd dirs expected by xend, bug #114856 (diff)
downloadhistorical-0ace72852c1b6f5a955f4286768c248bb9723a5d.tar.gz
historical-0ace72852c1b6f5a955f4286768c248bb9723a5d.tar.bz2
historical-0ace72852c1b6f5a955f4286768c248bb9723a5d.zip
rename cflags -> custom-cflags (like mplayer, grub..)
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/ChangeLog5
-rw-r--r--app-emulation/xen/Manifest4
-rw-r--r--app-emulation/xen/xen-3.0.0-r1.ebuild12
3 files changed, 12 insertions, 9 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index cb7ce40d1f65..2fbeccf2481e 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.18 2005/12/08 12:46:11 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.19 2005/12/08 12:55:33 chrb Exp $
+
+ 08 Dec 2005; <chrb@gentoo.org> xen-3.0.0-r1.ebuild:
+ rename cflags -> custom-cflags (like mplayer, grub..)
*xen-3.0.0-r1 (08 Dec 2005)
diff --git a/app-emulation/xen/Manifest b/app-emulation/xen/Manifest
index d8431d98e617..aa70a8e918c3 100644
--- a/app-emulation/xen/Manifest
+++ b/app-emulation/xen/Manifest
@@ -1,6 +1,6 @@
-MD5 fbc217d9828b738f9d09e846b2ac80f7 xen-3.0.0-r1.ebuild 2909
+MD5 e593104409de0b5b7246b6858ba0beb5 xen-3.0.0-r1.ebuild 2944
MD5 b25e5ad259e28bab5d8d3b4c0a62d278 xen-2.0.7.ebuild 2853
-MD5 d763d80421d79dda63d13eb661180c99 ChangeLog 3234
+MD5 ade183f42a66d72135ca08e1ede546a6 ChangeLog 3345
MD5 23ec60d5040f966fda250a47d8903428 metadata.xml 252
MD5 11ef318e35fcfed12931f182fc01955a files/xendomains-conf 180
MD5 f13640a07af78a60cfb562fa1d2088f3 files/xendomains-init 1659
diff --git a/app-emulation/xen/xen-3.0.0-r1.ebuild b/app-emulation/xen/xen-3.0.0-r1.ebuild
index 0ecb31b300fa..ea291c15f1ee 100644
--- a/app-emulation/xen/xen-3.0.0-r1.ebuild
+++ b/app-emulation/xen/xen-3.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.0-r1.ebuild,v 1.1 2005/12/08 12:46:11 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.0-r1.ebuild,v 1.2 2005/12/08 12:55:33 chrb Exp $
inherit mount-boot flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="doc debug screen cflags"
+IUSE="doc debug screen custom-cflags"
DEPEND="sys-apps/iproute2
net-misc/bridge-utils
@@ -34,11 +34,11 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
- # if the user *really* wants to use their own cflags, let them
- if use cflags; then
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"
for f in Makefile Rules.mk Config.mk; do
- # try and remove all the default cflags
+ # try and remove all the default custom-cflags
find ${S} -name ${f} -exec sed \
-e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
-e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
@@ -58,7 +58,7 @@ src_compile() {
myopt="${myopt} debug=y"
fi
- if ! use cflags; then
+ if ! use custom-cflags; then
unset CFLAGS
fi
filter-flags -fPIE -fstack-protector