summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-06-18 06:01:45 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-06-18 06:01:45 +0000
commit88ccf32261191bb8d94463cb301e3a97caa1227a (patch)
treec4a21e390b3fcba7c57daf287d769384ae5bf08d /app-emulation/winex-transgaming
parentnew version (diff)
downloadhistorical-88ccf32261191bb8d94463cb301e3a97caa1227a.tar.gz
historical-88ccf32261191bb8d94463cb301e3a97caa1227a.tar.bz2
historical-88ccf32261191bb8d94463cb301e3a97caa1227a.zip
new version
Diffstat (limited to 'app-emulation/winex-transgaming')
-rw-r--r--app-emulation/winex-transgaming/Manifest5
-rw-r--r--app-emulation/winex-transgaming/files/digest-winex-transgaming-3.10
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-3.1.ebuild61
3 files changed, 63 insertions, 3 deletions
diff --git a/app-emulation/winex-transgaming/Manifest b/app-emulation/winex-transgaming/Manifest
index e573d8b982be..ebee8e4c1093 100644
--- a/app-emulation/winex-transgaming/Manifest
+++ b/app-emulation/winex-transgaming/Manifest
@@ -1,8 +1,7 @@
-MD5 c7df55b9b7d29fdac20f6353274a5914 winex-transgaming-3.1.ebuild 2045
+MD5 629b445153be25f2f2d8d5cad08223df winex-transgaming-3.1.ebuild 2045
MD5 9fd8229b701d850e3084ac1a096b070f winex-transgaming-2.2.1.ebuild 2032
-MD5 238a0b31a971154af9d0e0dcb20318b5 ChangeLog.~1.5.~ 1622
MD5 c7df55b9b7d29fdac20f6353274a5914 winex-transgaming-3.0.ebuild 2045
-MD5 4ec8d928ce2e497be1e19c548fe48a37 ChangeLog 1760
+MD5 0115f1d13bdd46ad2627b51653be757c ChangeLog 1760
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-winex-transgaming-3.0 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-winex-transgaming-3.1 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-winex-transgaming-2.2.1 0
diff --git a/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.1 b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.1
diff --git a/app-emulation/winex-transgaming/winex-transgaming-3.1.ebuild b/app-emulation/winex-transgaming/winex-transgaming-3.1.ebuild
new file mode 100644
index 000000000000..4cf52a5a38f1
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-3.1.ebuild,v 1.1 2003/06/18 06:01:31 lordvan Exp $
+
+IUSE="cups opengl"
+
+MY_P="winex3_${PV}-1.i386"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="3"
+KEYWORDS="~x86"
+LICENSE="Aladdin"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+
+src_unpack () {
+ if [ ! -e "${DISTDIR}/${MY_P}.tgz" ] ; then
+ eerror ""
+ eerror "Please download the appropriate WineX archive (${MY_P}.tgz)"
+ eerror "from: ${HOMEPAGE} (requires a Transgaming subscription)."
+ eerror ""
+ eerror "The archive should be placed into ${DISTDIR}."
+ eerror ""
+
+ die "package archive (${MY_P}.tgz) not found"
+ fi
+ unpack "${MY_P}.tgz"
+}
+
+src_install () {
+ mv "${WORKDIR}/usr" "${D}"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/winex3 to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+}