summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 01:28:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 01:28:47 +0000
commitc1d71c69c325abf349a292f4997b800c018ae6a9 (patch)
tree7890af211d2f46beae70fc4362548dcd35515efe /app-emulation/winesetuptk
parentAdded package for Intel's Math Kernel Library. (diff)
downloadhistorical-c1d71c69c325abf349a292f4997b800c018ae6a9.tar.gz
historical-c1d71c69c325abf349a292f4997b800c018ae6a9.tar.bz2
historical-c1d71c69c325abf349a292f4997b800c018ae6a9.zip
de-bloated the DEPEND list
Diffstat (limited to 'app-emulation/winesetuptk')
-rw-r--r--app-emulation/winesetuptk/ChangeLog9
-rw-r--r--app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b-r11
-rw-r--r--app-emulation/winesetuptk/winesetuptk-0.6.0b-r1.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/app-emulation/winesetuptk/ChangeLog b/app-emulation/winesetuptk/ChangeLog
index 8cb591965eec..9474a4c7149c 100644
--- a/app-emulation/winesetuptk/ChangeLog
+++ b/app-emulation/winesetuptk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/winesetuptk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.1 2002/04/04 03:53:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.2 2002/04/27 01:28:47 seemant Exp $
+
+*winesetuptk-0.6.0b-r1 (26 Apr 2002)
+
+ 26 Apr 2002; Seemant Kulleen <seemant@gentoo.org> winesetuptk-0.6.0b-r1.ebuild :
+
+ It was pointed out indirectly by a new user that tcl and tk are NOT required
+ since this package links statically with them. Hooray for de-bloat!
*winesetuptk-0.6.0b (3 Apr 2002)
diff --git a/app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b-r1 b/app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b-r1
new file mode 100644
index 000000000000..953260f48d9f
--- /dev/null
+++ b/app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b-r1
@@ -0,0 +1 @@
+MD5 e5ce908158445ee7defd38e8fcd8a7b3 winesetuptk_0.6.0b-1.tar.gz 6810670
diff --git a/app-emulation/winesetuptk/winesetuptk-0.6.0b-r1.ebuild b/app-emulation/winesetuptk/winesetuptk-0.6.0b-r1.ebuild
new file mode 100644
index 000000000000..bcd36423c8e9
--- /dev/null
+++ b/app-emulation/winesetuptk/winesetuptk-0.6.0b-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Seemant Kulleen <seemant@rocketmail.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/winesetuptk-0.6.0b-r1.ebuild,v 1.1 2002/04/27 01:28:47 seemant Exp $
+
+MY_P=${PN}_${PV}-1.tar.gz
+PRE=tcltk-winesetuptk-0.6.0b
+SEC=winesetuptk-0.6.0b
+S=${WORKDIR}/${P}
+DESCRIPTION="Setup tool for WiNE adapted from Codeweavers by Debian"
+SRC_URI="http://ftp.debian.org/debian/pool/main/w/winesetuptk/${MY_P}"
+HOMEPAGE="http://packages.debian.org/unstable/otherosfs/winesetuptk.html"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+
+RDEPEND="app-emulation/wine"
+
+src_unpack() {
+
+ unpack ${MY_P}
+ cd ${S}
+
+ tar zxf ${PRE}.tar.gz
+ tar zxf ${SEC}.tar.gz
+
+}
+
+src_compile() {
+
+ cd ${S}/${PRE}
+ ./build.sh
+
+
+ cd ${S}/${SEC}
+
+ local myconf
+
+ myconf="${myconf} --with-tcltk=${S}/${PRE}"
+ myconf="${myconf} --with-launcher=/usr/bin --with-exe=/usr/bin"
+ myconf="${myconf} --with-doc=/usr/share/doc/${P}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ cd ${S}/${SEC}
+ make \
+ PREFIX_LAUNCHER=${D}/usr/bin \
+ PREFIX_EXE=${D}/usr/bin \
+ PREFIX_DOC=${D}/usr/share/doc/${P} \
+ install || die
+
+}