summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-12 06:41:34 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-12 06:41:34 +0000
commitb3db1c287eb9952effb9d63598b66f96c9f84c2a (patch)
tree0dd2bdd16ddc6c19f093aba3c68390987d8d09e5 /app-emulation/wine
parentVersion bumped (diff)
downloadhistorical-b3db1c287eb9952effb9d63598b66f96c9f84c2a.tar.gz
historical-b3db1c287eb9952effb9d63598b66f96c9f84c2a.tar.bz2
historical-b3db1c287eb9952effb9d63598b66f96c9f84c2a.zip
Version bumped
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/Manifest8
-rw-r--r--app-emulation/wine/files/digest-wine-200307094
-rw-r--r--app-emulation/wine/wine-20030709.ebuild133
3 files changed, 143 insertions, 2 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 318ddf61ae40..0d40a80abfe1 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,12 +1,16 @@
-MD5 00d9926df5aaae7aa09d6c3c4aceee3f ChangeLog 9121
+MD5 17f2bf4f2ff61298f602e07eb843a245 ChangeLog 9240
MD5 cf7820d37da40ca549fdecbc8942ba50 wine-20030411-r1.ebuild 3312
MD5 62de78f5d52d478759bd45a85b8c82b4 wine-20030508.ebuild 3510
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 db55bb70ba0f0adcc57a4550af4924af wine-20030618-r1.ebuild 3698
MD5 03402d805ec87326fb636bd1bd29f03f wine-20030618.ebuild 3623
-MD5 356173cea5472763bfe55ae99c659ccf wine-20030709.ebuild 3581
+MD5 de0cac62b6063f93149c01540f283137 wine-20030709.ebuild 3576
MD5 f405c0acec0e14b060af6098195c9881 files/digest-wine-20030709 282
+MD5 dcd68f96e0066c424ec1ceb8411c7549 files/digest-wine-20030411-r1 67
+MD5 b0780073e1d513fb7658070bba8d0672 files/digest-wine-20030508 284
+MD5 bf24bbde88c8128df0743ebe3ee2aa43 files/digest-wine-20030618 351
MD5 34704c0d512d1602202b29b0f42ed514 files/kpp-fix.patch 1235
MD5 af8da46a0e51578ff1e18e399141d628 files/wine-20030411-fake_windows.tar.bz2 500
MD5 8052677213b772973d85623012d68e86 files/wine-20030411-misc.tar.bz2 4591
MD5 bb9d5f77ffee8e72cf714aebc874157a files/wine-20030411-xopenfont.patch 1069
+MD5 bf24bbde88c8128df0743ebe3ee2aa43 files/digest-wine-20030618-r1 351
diff --git a/app-emulation/wine/files/digest-wine-20030709 b/app-emulation/wine/files/digest-wine-20030709
new file mode 100644
index 000000000000..cf7dd691362f
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20030709
@@ -0,0 +1,4 @@
+MD5 c26e151ecd49545afd5b15c1a4d726cc Wine-20030709.tar.gz 9026020
+MD5 fa4393cbc288ea89f761ad8d9258cc68 wine-20030709-xopenfont.patch 833
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20030709-fake_windows.tar.bz2 500
+MD5 8052677213b772973d85623012d68e86 wine-20030709-misc.tar.bz2 4591
diff --git a/app-emulation/wine/wine-20030709.ebuild b/app-emulation/wine/wine-20030709.ebuild
new file mode 100644
index 000000000000..8ebf46d92023
--- /dev/null
+++ b/app-emulation/wine/wine-20030709.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030709.ebuild,v 1.1 2003/07/12 06:41:18 mholzer Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${P}-xopenfont.patch
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${P}-misc.tar.bz2"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ epatch ${DISTDIR}/${P}-xopenfont.patch
+
+ cd ${S}/dlls/oleaut32/
+ patch -R < ${FILESDIR}/kpp-fix.patch
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="$myconf --enable-opengl" || myconf="$myconf --disable-opengl"
+ use nptl && myconf="$myconf --with-nptl" || myconf="$myconf --without-nptl"
+
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}