summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-06-25 03:51:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-06-25 03:51:36 +0000
commitfc9e67a3d8b0d5b08af9c19b0a801649b26106c1 (patch)
treea1a0bf07ab22cf21b7bac11aea4c70cd822d2a88 /app-emulation/virt-manager/virt-manager-0.10.0.ebuild
parentUpdate init.d scripts to use vars from the config file. Disable growl by def... (diff)
downloadhistorical-fc9e67a3d8b0d5b08af9c19b0a801649b26106c1.tar.gz
historical-fc9e67a3d8b0d5b08af9c19b0a801649b26106c1.tar.bz2
historical-fc9e67a3d8b0d5b08af9c19b0a801649b26106c1.zip
Handful of eclass usage fixes. Nothing like getting our GNOME/gconf/gsettings bits to play nice with our new Python eclass bits.
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64 Manifest-Sign-Key: 0xD7DFA8D318FA9AEF!
Diffstat (limited to 'app-emulation/virt-manager/virt-manager-0.10.0.ebuild')
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
index 26f0cb8d012d..d11020687de7 100644
--- a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.1 2013/06/24 13:28:45 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.2 2013/06/25 03:51:18 cardoe Exp $
EAPI=5
@@ -9,7 +9,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
#PYTHON_REQ_USE=""
-inherit eutils distutils-r1 fdo-mime gnome2-utils
+inherit eutils gnome2 distutils-r1
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="http://virt-manager.org"
@@ -32,8 +32,10 @@ RDEPEND="!app-emulation/virtinst
x11-libs/gtk+:3[introspection]
>=app-emulation/libvirt-0.7.0[python]
>=app-emulation/libvirt-glib-0.0.9
+ ${PYTHON_DEPS}
dev-libs/libxml2[python,${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/urlgrabber[${PYTHON_USEDEP}]
x11-libs/vte:2.90[glade,introspection]
gnome-keyring? ( dev-python/gnome-keyring-python )
@@ -61,15 +63,3 @@ distutils-r1_python_compile() {
--qemu-user=qemu \
--default-graphics=${defgraphics}
}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- fdo-mime_desktop_database_update
-}