summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-14 06:29:44 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-14 06:29:44 +0000
commit0319fabce89337cdc6677dac01b367b9a88f9aa9 (patch)
tree36145d7e0ec5a2430d752987a3f9dfb11478522d /app-emulation/psemu-spunull
parentgames.eclass support (diff)
downloadhistorical-0319fabce89337cdc6677dac01b367b9a88f9aa9.tar.gz
historical-0319fabce89337cdc6677dac01b367b9a88f9aa9.tar.bz2
historical-0319fabce89337cdc6677dac01b367b9a88f9aa9.zip
initial ebuild
Diffstat (limited to 'app-emulation/psemu-spunull')
-rw-r--r--app-emulation/psemu-spunull/ChangeLog8
-rw-r--r--app-emulation/psemu-spunull/files/1.0-makefile-cflags.patch11
-rw-r--r--app-emulation/psemu-spunull/files/digest-psemu-spunull-1.01
-rw-r--r--app-emulation/psemu-spunull/psemu-spunull-1.0.ebuild33
4 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/psemu-spunull/ChangeLog b/app-emulation/psemu-spunull/ChangeLog
new file mode 100644
index 000000000000..1581e6d32422
--- /dev/null
+++ b/app-emulation/psemu-spunull/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/psemu-spunull
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-spunull/ChangeLog,v 1.1 2003/08/14 06:29:44 vapier Exp $
+
+*psemu-spunull-1.0 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/app-emulation/psemu-spunull/files/1.0-makefile-cflags.patch b/app-emulation/psemu-spunull/files/1.0-makefile-cflags.patch
new file mode 100644
index 000000000000..0abfdb3e74cf
--- /dev/null
+++ b/app-emulation/psemu-spunull/files/1.0-makefile-cflags.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.orig 2003-08-14 01:41:28.679161896 -0400
++++ src/Makefile 2003-08-14 01:41:38.590655120 -0400
+@@ -1,7 +1,7 @@
+
+ VERSION = 1.0
+ PLUGIN = libspunull-${VERSION}.so
+-CFLAGS+= -fPIC -Wall -O2 -fomit-frame-pointer
++CFLAGS+= -fPIC -Wall $(OPTFLAGS)
+ OBJECTS = spu.o
+
+ all: plugin
diff --git a/app-emulation/psemu-spunull/files/digest-psemu-spunull-1.0 b/app-emulation/psemu-spunull/files/digest-psemu-spunull-1.0
new file mode 100644
index 000000000000..d3c2a483bdf8
--- /dev/null
+++ b/app-emulation/psemu-spunull/files/digest-psemu-spunull-1.0
@@ -0,0 +1 @@
+MD5 da55fd85d3da5e5f9507449fe955e21b spunull-1.0.tgz 7056
diff --git a/app-emulation/psemu-spunull/psemu-spunull-1.0.ebuild b/app-emulation/psemu-spunull/psemu-spunull-1.0.ebuild
new file mode 100644
index 000000000000..3fa99296085f
--- /dev/null
+++ b/app-emulation/psemu-spunull/psemu-spunull-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-spunull/psemu-spunull-1.0.ebuild,v 1.1 2003/08/14 06:29:44 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="PSEmu plugin to use a null sound driver"
+HOMEPAGE="http://www.pcsx.net/"
+SRC_URI="http://linuzappz.pcsx.net/downloads/spunull-${PV}.tgz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+}
+
+src_compile() {
+ cd src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd src
+ exeinto ${GAMES_LIBDIR}/psemu/plugins
+ doexe libspunull-*
+ prepgamesdirs
+}