summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2008-08-10 21:06:51 +0000
committerMike Doty <kingtaco@gentoo.org>2008-08-10 21:06:51 +0000
commit5eb06ff47d01d163a1cbf4eb1c42e5ec9d048c97 (patch)
tree1d19685075fc0b6a6eb5dc5caba39156b0bdbe38 /app-emulation/emul-linux-x86-soundlibs
parentCloses bug 220285 and adds back the speech engines for bug 211214.. (diff)
downloadhistorical-5eb06ff47d01d163a1cbf4eb1c42e5ec9d048c97.tar.gz
historical-5eb06ff47d01d163a1cbf4eb1c42e5ec9d048c97.tar.bz2
historical-5eb06ff47d01d163a1cbf4eb1c42e5ec9d048c97.zip
version bump
Package-Manager: portage-2.1.5.6
Diffstat (limited to 'app-emulation/emul-linux-x86-soundlibs')
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/ChangeLog8
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20080810.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-soundlibs/ChangeLog b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
index 46a57b752cd3..6fcf67de76d9 100644
--- a/app-emulation/emul-linux-x86-soundlibs/ChangeLog
+++ b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/emul-linux-x86-soundlibs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.39 2008/06/22 09:52:57 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.40 2008/08/10 21:05:14 kingtaco Exp $
+
+*emul-linux-x86-soundlibs-20080810 (10 Aug 2008)
+
+ 10 Aug 2008; Mike Doty <kingtaco@gentoo.org>
+ +emul-linux-x86-soundlibs-20080810.ebuild:
+ version bump
22 Jun 2008; <welp@gentoo.org> emul-linux-x86-soundlibs-20080418.ebuild:
Stable on amd64; bug 222759
diff --git a/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20080810.ebuild b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20080810.ebuild
new file mode 100644
index 000000000000..4d45510db425
--- /dev/null
+++ b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20080810.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20080810.ebuild,v 1.1 2008/08/10 21:05:14 kingtaco Exp $
+
+inherit emul-linux-x86
+
+LICENSE="as-is BSD GPL-2 LGPL-2 LGPL-2.1 Adobe-SourceCode"
+KEYWORDS="-* ~amd64"
+IUSE="arts esd alsa"
+
+RDEPEND=">=app-emulation/emul-linux-x86-baselibs-20071114
+ >=app-emulation/emul-linux-x86-medialibs-20071114
+ >=app-emulation/emul-linux-x86-xlibs-20080810"
+
+src_unpack() {
+ _ALLOWED="${S}/etc/env.d"
+
+ if use alsa; then
+ _ALLOWED="${_ALLOWED}|${S}/usr/bin/aoss"
+ fi
+
+ if use esd; then
+ _ALLOWED="${_ALLOWED}|${S}/usr/bin/esddsp"
+ fi
+
+ if use arts; then
+ _ALLOWED="${_ALLOWED}|${S}/usr/kde/.*/bin/artsdsp"
+ fi
+ ALLOWED="(${_ALLOWED})"
+
+ emul-linux-x86_src_unpack
+
+ mv -f "${S}"/usr/bin/aoss{,32}
+ mv -f "${S}"/usr/kde/3.5/bin/artsdsp{,32}
+ mv -f "${S}"/usr/bin/esddsp{,32}
+
+ if ! use arts; then
+ rm -rf "${S}"/usr/kde/
+ fi
+}