summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-25 04:51:08 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-25 04:51:08 +0000
commita5385eacd6aaf69ee0a8be98f0fe6fff6784b455 (patch)
tree25c6a23a5fce4e4cd296878848ac9bf38b0d2a1c /app-emacs
parentcloses 29542 (diff)
downloadhistorical-a5385eacd6aaf69ee0a8be98f0fe6fff6784b455.tar.gz
historical-a5385eacd6aaf69ee0a8be98f0fe6fff6784b455.tar.bz2
historical-a5385eacd6aaf69ee0a8be98f0fe6fff6784b455.zip
closes 29542
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/thumbs/Manifest9
-rw-r--r--app-emacs/thumbs/files/50thumbs-gentoo.el1
-rw-r--r--app-emacs/thumbs/files/digest-thumbs-1.81
-rw-r--r--app-emacs/thumbs/files/thumbs.el-gentoo.patch16
-rw-r--r--app-emacs/thumbs/thumbs-1.8.ebuild36
5 files changed, 58 insertions, 5 deletions
diff --git a/app-emacs/thumbs/Manifest b/app-emacs/thumbs/Manifest
index b60e1a604c06..4b0442f228c6 100644
--- a/app-emacs/thumbs/Manifest
+++ b/app-emacs/thumbs/Manifest
@@ -1,8 +1,7 @@
-MD5 d9aff0535538fa66ef81837223debbff ChangeLog 406
+MD5 8dab500df6a8ec3e18db0dd5346341b5 ChangeLog 601
MD5 4bf92de36371d8591cd2d1ef019ea7a0 thumbs-0.8.1.ebuild 900
-MD5 f032b07ff5736361b5ccc2f97cce706b thumbs-1.8.ebuild 738
-MD5 4bf92de36371d8591cd2d1ef019ea7a0 thumbs-1.8.ebuild~ 900
-MD5 504e791d0d2035ae12069e6fb8eb4d4d files/50thumbs-gentoo.el 102
+MD5 b6573b1e9496dac50f4dee436a646f11 thumbs-1.8.ebuild 810
+MD5 7de52a52a8d47b90c0eb6593c8d7894b files/50thumbs-gentoo.el 119
MD5 775e38291c21b17e0b0c4a8f8341decd files/digest-thumbs-0.8.1 63
-MD5 40b611dcc7121fc11eeaeaccd48ae1ea files/semantic.cache 362
MD5 98ec879de6ba9c65d17698d59f6e9981 files/digest-thumbs-1.8 60
+MD5 f6524318a33281d5bb3005cc5909a4b8 files/thumbs.el-gentoo.patch 651
diff --git a/app-emacs/thumbs/files/50thumbs-gentoo.el b/app-emacs/thumbs/files/50thumbs-gentoo.el
index 694295d20873..dd1aaf12cd2a 100644
--- a/app-emacs/thumbs/files/50thumbs-gentoo.el
+++ b/app-emacs/thumbs/files/50thumbs-gentoo.el
@@ -2,4 +2,5 @@
;;; thumbs site-lisp configuration
(setq load-path (cons "@SITELISP@" load-path))
+(require 'image)
(require 'thumbs)
diff --git a/app-emacs/thumbs/files/digest-thumbs-1.8 b/app-emacs/thumbs/files/digest-thumbs-1.8
new file mode 100644
index 000000000000..d8ada0f6ff41
--- /dev/null
+++ b/app-emacs/thumbs/files/digest-thumbs-1.8
@@ -0,0 +1 @@
+MD5 27a6326c150ac5da9c5b418b6c22cf7b thumbs-1.8.tar.gz 7149
diff --git a/app-emacs/thumbs/files/thumbs.el-gentoo.patch b/app-emacs/thumbs/files/thumbs.el-gentoo.patch
new file mode 100644
index 000000000000..5c9767560731
--- /dev/null
+++ b/app-emacs/thumbs/files/thumbs.el-gentoo.patch
@@ -0,0 +1,16 @@
+diff -u thumbs-1.8.orig/thumbs.el thumbs-1.8/thumbs.el
+--- thumbs-1.8.orig/thumbs.el 2003-09-24 18:01:22.000000000 -0500
++++ thumbs-1.8/thumbs.el 2003-09-24 23:44:24.834705392 -0500
+@@ -48,11 +48,6 @@
+
+ (defconst xemacsp (string-match "XEmacs" emacs-version))
+
+-(if (and (not xemacsp)(not (featurep 'image)))
+- (error "Your Emacs version (%S) doesn't support in-line images or was not compiled with image support.
+-Upgrade to Emacs 21.1 or newer, or compile it with image support."
+- emacs-version))
+-
+ (if (not (fboundp 'image-file-name-regexp))
+ (defun image-file-name-regexp ()
+ (let ((reg
+Only in thumbs-1.8: thumbs.el~
diff --git a/app-emacs/thumbs/thumbs-1.8.ebuild b/app-emacs/thumbs/thumbs-1.8.ebuild
new file mode 100644
index 000000000000..a03e0c5ef50a
--- /dev/null
+++ b/app-emacs/thumbs/thumbs-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/thumbs-1.8.ebuild,v 1.1 2003/09/25 04:51:05 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs thumbnail previewer for image files"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki.pl?ThumbsMode"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ media-gfx/imagemagick"
+
+S=${WORKDIR}/${P}
+
+SITEFILE=50thumbs-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/thumbs.el-gentoo.patch
+}
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+