summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/wl
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/wl')
-rw-r--r--app-emacs/wl/ChangeLog11
-rw-r--r--app-emacs/wl/files/70wl-gentoo.el10
-rw-r--r--app-emacs/wl/files/digest-wl-2.8.11
-rw-r--r--app-emacs/wl/wl-2.8.1.ebuild56
4 files changed, 78 insertions, 0 deletions
diff --git a/app-emacs/wl/ChangeLog b/app-emacs/wl/ChangeLog
new file mode 100644
index 000000000000..3f87d8bfaf06
--- /dev/null
+++ b/app-emacs/wl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/wl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wl/ChangeLog,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+*wl-2.8.1 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ wl-2.8.1.ebuild, files/70wl-gentoo.el,
+ files/digest-wl-2.8.1 :
+
+ Initial import.
diff --git a/app-emacs/wl/files/70wl-gentoo.el b/app-emacs/wl/files/70wl-gentoo.el
new file mode 100644
index 000000000000..8aa46ec18901
--- /dev/null
+++ b/app-emacs/wl/files/70wl-gentoo.el
@@ -0,0 +1,10 @@
+
+;;; Wanderlust site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
+(autoload 'wl "wl" "Wanderlust" t)
+(autoload 'wl-other-frame "wl" "Wanderlust on new frame." t)
+(autoload 'wl-draft "wl-draft" "Write draft with Wanderlust." t)
+
+(setq wl-icon-directory "/usr/share/wl/icons")
diff --git a/app-emacs/wl/files/digest-wl-2.8.1 b/app-emacs/wl/files/digest-wl-2.8.1
new file mode 100644
index 000000000000..af59f295815c
--- /dev/null
+++ b/app-emacs/wl/files/digest-wl-2.8.1
@@ -0,0 +1 @@
+MD5 8a11da5eb8b5990c0c0d99216e29e1ac wl-2.8.1.tar.gz 1040012
diff --git a/app-emacs/wl/wl-2.8.1.ebuild b/app-emacs/wl/wl-2.8.1.ebuild
new file mode 100644
index 000000000000..72f37fb58e75
--- /dev/null
+++ b/app-emacs/wl/wl-2.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wl/wl-2.8.1.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Wanderlust is a mail/news reader supporting IMAP4rev1 for emacsen"
+HOMEPAGE="http://www.gohome.org/wl/index.html"
+SRC_URI="ftp://ftp.gohome.org/wl/stable/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ >=app-emacs/apel-10.3
+ >=app-emacs/flim-1.14.3
+ >=app-emacs/semi-1.14.3"
+# >=virtual/flim-1.14.3
+# >=virtual/semi-1.14.3
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ make || die;
+ make info || die;
+}
+
+src_install() {
+
+ make \
+ LISPDIR=${D}/usr/share/emacs/site-lisp \
+ PIXMAPDIR=${D}/usr/share/${PN}/icons \
+ install || die
+
+ elisp-site-file-install ${FILESDIR}/70wl-gentoo.el
+
+ dodir /usr/share/${PN}/samples
+
+ insinto /usr/share/${PN}/samples
+ doins samples/*
+
+ doinfo doc/wl-ja.info doc/wl.info
+ dodoc BUGS* COPYING ChangeLog INSTALL* README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P}/INSTALL.gz."
+ einfo "And Sample configuration files exist on /usr/share/${PN}/samples."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}