summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/table/table-1.5.53.ebuild
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/table/table-1.5.53.ebuild')
-rw-r--r--app-emacs/table/table-1.5.53.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/table/table-1.5.53.ebuild b/app-emacs/table/table-1.5.53.ebuild
new file mode 100644
index 000000000000..4567dd2530a5
--- /dev/null
+++ b/app-emacs/table/table-1.5.53.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/table-1.5.53.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Table editor for Emacs"
+HOMEPAGE="http://table.sourceforge.net/"
+SRC_URI="mirror://sourceforge/table/${P}.el.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/"
+
+SITEFILE=50table-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && mv ${P}.el ${PN}.el
+}
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/table.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}