summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2007-10-08 23:23:06 +0000
committerChristian Faulhammer <fauli@gentoo.org>2007-10-08 23:23:06 +0000
commit7905e1d2fdc3ca7b4dc524463c63966920bbb41d (patch)
tree28c390673222ec782fa06974d093d3443b8d362c /app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild
parentstable x86, bug 195158 (diff)
downloadhistorical-7905e1d2fdc3ca7b4dc524463c63966920bbb41d.tar.gz
historical-7905e1d2fdc3ca7b4dc524463c63966920bbb41d.tar.bz2
historical-7905e1d2fdc3ca7b4dc524463c63966920bbb41d.zip
version bump
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild')
-rw-r--r--app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild b/app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild
new file mode 100644
index 000000000000..97bc37891284
--- /dev/null
+++ b/app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ruby-mode/ruby-mode-1.8.6.ebuild,v 1.1 2007/10/08 23:23:06 opfer Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Ruby code"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/ruby-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}/ruby-${PV}/misc"
+
+src_compile() {
+ elisp-comp *.el || die
+}