summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-09-04 04:46:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-09-04 04:46:25 +0000
commit91b1e82c45cebcecb994c962a80a0f51bad96bdd (patch)
treed3c11756c218137a003508e13c9611c752c1349a /app-emacs/emms/emms-2.1.ebuild
parentMarked 0.2.8.3-r1 && 0.2.8.4 stable on mips. (diff)
downloadhistorical-91b1e82c45cebcecb994c962a80a0f51bad96bdd.tar.gz
historical-91b1e82c45cebcecb994c962a80a0f51bad96bdd.tar.bz2
historical-91b1e82c45cebcecb994c962a80a0f51bad96bdd.zip
New upstream version.
Package-Manager: portage-2.1.1_pre5-r3
Diffstat (limited to 'app-emacs/emms/emms-2.1.ebuild')
-rw-r--r--app-emacs/emms/emms-2.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/emms/emms-2.1.ebuild b/app-emacs/emms/emms-2.1.ebuild
new file mode 100644
index 000000000000..8f2ed2ecc6bf
--- /dev/null
+++ b/app-emacs/emms/emms-2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emms/emms-2.1.ebuild,v 1.1 2006/09/04 04:46:24 mkennedy Exp $
+
+inherit elisp toolchain-funcs eutils
+
+DESCRIPTION="EMMS is the Emacs Multimedia System"
+HOMEPAGE="http://www.gnu.org/software/emms/ http://www.emacswiki.org/cgi-bin/wiki/EMMS"
+SRC_URI="http://www.gnu.org/software/emms/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+IUSE=""
+
+RDEPEND="virtual/emacs"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ media-libs/taglib"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# posibilities are so broad that we refrain from setting anything explicitly in
+# DEPEND/RDEPEND.
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/2.0-taglib-Makefile-gentoo.patch
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" \
+ EMACS=emacs \
+ DESTDIR=/usr/share/emacs/site-lisp/emms \
+ all emms-print-metadata \
+ || die
+}
+
+src_install() {
+ elisp-install emms *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/50emms-gentoo.el
+ dodoc AUTHORS ChangeLog FAQ README RELEASE
+ doinfo *.info*
+ dobin *-wrapper emms-print-metadata
+}