summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2002-11-21 01:39:00 +0000
committerJohn P. Davis <zhen@gentoo.org>2002-11-21 01:39:00 +0000
commit448b2549efb5222a63a84298e02be9715ff9f2c4 (patch)
tree7544d085dc0aa1e536c5ea35dc5643f64af6b50f /app-editors
parentversion bump (diff)
downloadhistorical-448b2549efb5222a63a84298e02be9715ff9f2c4.tar.gz
historical-448b2549efb5222a63a84298e02be9715ff9f2c4.tar.bz2
historical-448b2549efb5222a63a84298e02be9715ff9f2c4.zip
added UTF-8 compatibility
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/ChangeLog12
-rw-r--r--app-editors/gvim/files/digest-gvim-6.1-r42
-rw-r--r--app-editors/gvim/gvim-6.1-r4.ebuild87
-rw-r--r--app-editors/vim/files/digest-vim-6.1-r172
-rw-r--r--app-editors/vim/vim-6.1-r17.ebuild61
5 files changed, 162 insertions, 2 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index 1cb72ee061f5..0334c0ea9982 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for app-editors/gvim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.6 2002/11/12 22:34:23 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.7 2002/11/21 01:33:47 zhen Exp $
- 16 Sep 2002; Hannes Mehnert <hannes@gentoo.org> gvim-6.1.ebuild:
+*gvim-6.1-r4.ebuild (20 Nov 2002)
+
+ 20 Nov 2002; John P. Davis <zhen@gentoo.org> gvim-6.1-r4.ebuild :
+
+ Added support for UTF-8 (unicode). Changed myconf to build these
+ options in default.
+
+
+16 Sep 2002; Hannes Mehnert <hannes@gentoo.org> gvim-6.1.ebuild:
added dependency app-editors/vim-core
14 Sep 2002; Hannes Mehnert <hannes@gentoo.org> gvim-6.1.ebuild:
diff --git a/app-editors/gvim/files/digest-gvim-6.1-r4 b/app-editors/gvim/files/digest-gvim-6.1-r4
new file mode 100644
index 000000000000..63796185e7f4
--- /dev/null
+++ b/app-editors/gvim/files/digest-gvim-6.1-r4
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 80747ac21d83777aeefb714f7a385b11 vimpatch-1-245.tar.bz2 191362
diff --git a/app-editors/gvim/gvim-6.1-r4.ebuild b/app-editors/gvim/gvim-6.1-r4.ebuild
new file mode 100644
index 000000000000..a9ddc0e45359
--- /dev/null
+++ b/app-editors/gvim/gvim-6.1-r4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r4.ebuild,v 1.1 2002/11/21 01:34:34 zhen Exp $
+
+inherit vim
+DESCRIPTION="graphical vim"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND="dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ sys-libs/libtermcap-compat
+ app-editors/vim-core
+ x11-base/xfree
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gnome? ( gnome-base/gnome-libs )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+# It appears that the tclinterp stuff in Vim is broken right now (at
+# least on Linux... it works on BSD). When you --enable-tclinterp
+# flag, then the following command never returns:
+#
+# VIMINIT='let OS = system("uname -s")' vim
+#
+# Please don't re-enable the tclinterp flag without verifying first
+# that the above works. Thanks. (08 Sep 2001 agriffis)
+
+src_compile() {
+ #default myconf options added by ZhEN on 11/20/02 for unicode support
+ local myconf="--with-features=big --enable-multibyte"
+ use nls && myconf="--enable-multibyte" || myconf="--disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ if use gnome; then
+ guiconf="--enable-gui=gnome --with-x"
+ elif use gtk; then
+ guiconf="--enable-gui=gtk --with-x"
+ else
+ guiconf="--enable-gui=athena --with-x"
+ fi
+
+ # This should fix a sandbox violation.
+ addwrite /dev/pty/*
+
+ if [ -n "$guiconf" ]; then
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --enable-cscope $myconf $guiconf \
+ --with-vim-name=gvim || die "gvim configure failed"
+ # Parallel make does not work
+ make || die "gvim make failed"
+ fi
+}
+
+src_install() {
+ dobin src/gvim
+ ln -s gvim ${D}/usr/bin/gvimdiff
+ # Default gvimrc
+ insinto /usr/share/vim
+ doins ${FILESDIR}/gvimrc
+}
+
+#added by ZhEN 11/20/02 for unicode
+pkg_postinst() {
+ einfo
+ einfo "To enable UTF-8 viewing, set guifont and guifontwide: "
+ einfo ":set guifont=-misc-fixed-medium-r-normal-*-18-120-100-100-c-90-iso10646-1"
+ einfo ":set guifontwide=-misc-fixed-medium-r-normal-*-18-120-100-100-c-180-iso10646-1"
+ einfo
+ einfo "note: to find out which fonts you can use, please read the UTF-8 help:"
+ einfo ":h utf-8"
+ einfo
+ einfo "Then, set read encoding to UTF-8:"
+ einfo ":set encoding=utf-8"
+ einfo
+
+}
diff --git a/app-editors/vim/files/digest-vim-6.1-r17 b/app-editors/vim/files/digest-vim-6.1-r17
new file mode 100644
index 000000000000..63796185e7f4
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.1-r17
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 80747ac21d83777aeefb714f7a385b11 vimpatch-1-245.tar.bz2 191362
diff --git a/app-editors/vim/vim-6.1-r17.ebuild b/app-editors/vim/vim-6.1-r17.ebuild
new file mode 100644
index 000000000000..0e1e6fc25825
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.1 2002/11/21 01:39:00 zhen Exp $
+
+inherit vim
+
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND="app-editors/vim-core
+ sys-libs/libtermcap-compat
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+
+src_compile() {
+ local myconf
+ myconf="--without-x --with-features=big --enable-multibyte"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # This should fix a sandbox violation.
+ addwrite "${SSH_TTY}"
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --with-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ # Default vimrc
+ insinto /usr/share/vim
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}