summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-01-20 14:30:08 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-01-20 14:30:08 +0000
commit153b4c02b5b2b4ebda2ea788b8035b2b9cbc1583 (patch)
treedb8797e19be75c172c97a6898af57f6eb0197f25 /app-editors
parentStable on amd64 wrt bug #352144 (diff)
downloadhistorical-153b4c02b5b2b4ebda2ea788b8035b2b9cbc1583.tar.gz
historical-153b4c02b5b2b4ebda2ea788b8035b2b9cbc1583.tar.bz2
historical-153b4c02b5b2b4ebda2ea788b8035b2b9cbc1583.zip
initial revision.
Package-Manager: portage-2.1.9.25/cvs/Linux i686
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/aee/ChangeLog10
-rw-r--r--app-editors/aee/Manifest5
-rw-r--r--app-editors/aee/aee-2.2.15b.ebuild68
-rw-r--r--app-editors/aee/files/aee-ae-location.diff95
-rw-r--r--app-editors/aee/metadata.xml8
5 files changed, 186 insertions, 0 deletions
diff --git a/app-editors/aee/ChangeLog b/app-editors/aee/ChangeLog
new file mode 100644
index 000000000000..a1934c59117f
--- /dev/null
+++ b/app-editors/aee/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-editors/aee
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/aee/ChangeLog,v 1.1 2011/01/20 14:30:08 hattya Exp $
+
+*aee-2.2.15b (20 Jan 2011)
+
+ 20 Jan 2011; Akinori Hattori <hattya@gentoo.org> +aee-2.2.15b.ebuild,
+ +files/aee-ae-location.diff, +metadata.xml:
+ initial revision.
+
diff --git a/app-editors/aee/Manifest b/app-editors/aee/Manifest
new file mode 100644
index 000000000000..555280ad595b
--- /dev/null
+++ b/app-editors/aee/Manifest
@@ -0,0 +1,5 @@
+AUX aee-ae-location.diff 3120 RMD160 2d700010ce3c4ddb6b013df05cac188bc5289976 SHA1 f944f804078de109ea4a9a99e93088fd3d21ec80 SHA256 895f87be977ae3e9ea4d266b582f38b3a82c85ccf392ea22e303aa78d4fa60c5
+DIST aee-2.2.15b.tar.gz 184218 RMD160 b8b74c7714fcfa915eee5e88482c4ec47887133a SHA1 63ba64fe43e7c0d0b0b55d6ffd3a6b54ed47316c SHA256 7abbaffe35018f9de87c8685f9bee2ea3f261e88ce60674f1a5a9a3a0f54d752
+EBUILD aee-2.2.15b.ebuild 1160 RMD160 3b7520a10bcd4daccb74b790f05a40c93b0f87ae SHA1 cb7a06b56046e0b4d4d078864c857d20fcc1555f SHA256 4dd22b01d298dccb4e94a33bb027e1527db7580645ec759e872a7cecfd077668
+MISC ChangeLog 370 RMD160 66b69375bfd9046c962eaa2ec63ab9e50e84475e SHA1 68d7c452a2d70b5b09716ab32e5970fa5dd5d5f2 SHA256 870cc7de94da6117a8d2db3919b997eff751f1fc5ce51198cf97c3fcdba2035a
+MISC metadata.xml 230 RMD160 8e45109dbaf3c193afdb318002c1def7cb62dfa1 SHA1 9bd7aea9376c216b3f55303d1334a337cd6f06a2 SHA256 87fc07a55ee7814a0505ae1c24a871ac29ae7691c5383550647382a2b26277ae
diff --git a/app-editors/aee/aee-2.2.15b.ebuild b/app-editors/aee/aee-2.2.15b.ebuild
new file mode 100644
index 000000000000..17612f100d53
--- /dev/null
+++ b/app-editors/aee/aee-2.2.15b.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/aee/aee-2.2.15b.ebuild,v 1.1 2011/01/20 14:30:08 hattya Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+IUSE="X"
+
+DESCRIPTION="An easy to use text editor."
+HOMEPAGE="http://mahon.cwx.net/"
+SRC_URI="http://mahon.cwx.net/sources/${P}.tar.gz"
+
+LICENSE="Artistic"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND="X? ( x11-libs/libX11 )"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${PN}-*.diff
+
+ sed -i \
+ -e "s/make -/\$(MAKE) -/g" \
+ -e "/^buildaee/s/$/ localaee/" \
+ -e "/^buildxae/s/$/ localxae/" \
+ Makefile \
+ || die
+
+ sed -i \
+ -e "s/\([\t ]\)cc /\1\\\\\$(CC) /" \
+ -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
+ -e "/other_cflag/s/ \${strip_option}//" \
+ create.mk.{aee,xae} \
+ || die
+
+}
+
+src_compile() {
+
+ local target="aee"
+
+ if use X; then
+ target="both"
+ fi
+
+ emake ${target} || die
+
+}
+
+src_install() {
+
+ dobin aee
+ dosym aee /usr/bin/rae
+ doman aee.1
+ dodoc Changes README.aee aee.i18n.guide aee.msg
+
+ insinto /usr/share/${PN}
+ doins help.ae
+
+ if use X; then
+ dobin xae
+ dosym xae /usr/bin/rxae
+ fi
+
+}
diff --git a/app-editors/aee/files/aee-ae-location.diff b/app-editors/aee/files/aee-ae-location.diff
new file mode 100644
index 000000000000..86022005cb50
--- /dev/null
+++ b/app-editors/aee/files/aee-ae-location.diff
@@ -0,0 +1,95 @@
+diff -u aee-2.2.15b.orig/aee.1 aee-2.2.15b/aee.1
+--- aee-2.2.15b.orig/aee.1
++++ aee-2.2.15b/aee.1
+@@ -678,7 +678,7 @@
+ .\"
+ .SS Initializing aee From A File
+ .PP
+-\fIaee\fR checks for a file named \fIinit.ae\fR in \fI/usr/local/lib\fR,
++\fIaee\fR checks for a file named \fIinit.ae\fR in \fI/usr/share/aee\fR,
+ .I .init.ae
+ in the user's home directory, then for \fI.init.ae\fR in the
+ current directory. (This file may be created manually or by using the
+@@ -960,7 +960,7 @@
+ .PP
+ On-line help is provided through the 'help' command or menu item. This
+ command uses a file with help information. By default the help file is
+-located in \fB/usr/local/lib/help.ae\fR, but this file may be located
++located in \fB/usr/share/aee/help.ae\fR, but this file may be located
+ in the user's home directory with the name \fB.help.ae\fR, or in the
+ current directory with the name \fBhelp.ae\fR.
+ .\"
+@@ -1017,7 +1017,7 @@
+ .\"
+ .SH FILES
+ .PP
+-.I /usr/local/lib/init.ae
++.I /usr/share/aee/init.ae
+ .br
+ .I $HOME/.aeeinfo
+ .br
+diff -u aee-2.2.15b.orig/aee.c aee-2.2.15b/aee.c
+--- aee-2.2.15b.orig/aee.c
++++ aee-2.2.15b/aee.c
+@@ -2612,7 +2612,7 @@
+
+ char *init_name[4] = {
+ "/usr/local/aee/init.ae",
+- "/usr/local/lib/init.ae",
++ "/usr/share/aee/init.ae",
+ NULL,
+ ".init.ae"
+ };
+diff -u aee-2.2.15b.orig/aee.msg aee-2.2.15b/aee.msg
+--- aee-2.2.15b.orig/aee.msg
++++ aee-2.2.15b/aee.msg
+@@ -2,7 +2,7 @@
+ $
+ $set 1
+ $quote "
+-1 "/usr/local/lib/help.ae"
++1 "/usr/share/aee/help.ae"
+ 2 "main"
+ 3 "modes menu"
+ 4 "tabs to spaces "
+diff -u aee-2.2.15b.orig/help.ae aee-2.2.15b/help.ae
+--- aee-2.2.15b.orig/help.ae
++++ aee-2.2.15b/help.ae
+@@ -1058,11 +1058,11 @@
+
+ The file 'init.ae' may be used to set parameters and define keys to
+ perform certain functions within ae. This file may reside in three
+-locations: /usr/local/lib/init.ae, .init.ae in your home directory, and
++locations: /usr/share/aee/init.ae, .init.ae in your home directory, and
+ .init.ae in the current working directory.
+
+ First, aee checks for a system level initialization file, located in
+-/usr/local/lib. Next the user's home directory is checked for a file named
++/usr/share/aee. Next the user's home directory is checked for a file named
+ .init.ae, then the current directory. The settings from each file are read,
+ so that the directives from the most recently read file will take precedence
+ over previously read files. This allows, for example, the .init.ae file in
+diff -u aee-2.2.15b.orig/help.c aee-2.2.15b/help.c
+--- aee-2.2.15b.orig/help.c
++++ aee-2.2.15b/help.c
+@@ -12,7 +12,7 @@
+
+ char *help_file_list[4] = {
+ "/usr/local/aee/help.ae",
+- "/usr/local/lib/help.ae",
++ "/usr/share/aee/help.ae",
+ "~/.help.ae",
+ "help.ae"
+ };
+diff -u aee-2.2.15b.orig/localize.c aee-2.2.15b/localize.c
+--- aee-2.2.15b.orig/localize.c
++++ aee-2.2.15b/localize.c
+@@ -64,7 +64,7 @@
+ catalog = catopen("aee", 0);
+ #endif /* NO_CATGETS */
+
+- ae_help_file = catgetlocal( 1, "/usr/local/lib/help.ae");
++ ae_help_file = catgetlocal( 1, "/usr/share/aee/help.ae");
+ main_buffer_name = catgetlocal( 2, "main");
+
+
diff --git a/app-editors/aee/metadata.xml b/app-editors/aee/metadata.xml
new file mode 100644
index 000000000000..bfe33a26e11c
--- /dev/null
+++ b/app-editors/aee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>