summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-05-15 18:47:45 +0000
committerMamoru Komachi <usata@gentoo.org>2004-05-15 18:47:45 +0000
commite3a7147427440916203bfca40f58a8e7db3053c2 (patch)
tree425af7d5d632e20fe03c0ee7fc59c4170078420d /app-editors/ng
parent~amd64 (diff)
downloadhistorical-e3a7147427440916203bfca40f58a8e7db3053c2.tar.gz
historical-e3a7147427440916203bfca40f58a8e7db3053c2.tar.bz2
historical-e3a7147427440916203bfca40f58a8e7db3053c2.zip
Added inherit eutils
Diffstat (limited to 'app-editors/ng')
-rw-r--r--app-editors/ng/ChangeLog6
-rw-r--r--app-editors/ng/ng-1.5_beta1.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/app-editors/ng/ChangeLog b/app-editors/ng/ChangeLog
index adc990a01f7c..e02f4b2b58a9 100644
--- a/app-editors/ng/ChangeLog
+++ b/app-editors/ng/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for app-editors/ng
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ChangeLog,v 1.1 2004/05/15 18:19:20 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ChangeLog,v 1.2 2004/05/15 18:47:45 usata Exp $
*ng-1.5_beta1 (16 May 2004)
16 May 2004; Mamoru KOMACHI <usata@gentoo.org> ng-1.5_beta1.ebuild,
files/ng-1.5beta1-ncurses.patch:
Initial import. Ebuild submitted by Atsushi Kobayashi <loudear@iswebnet.com>,
- closing bug #50823
-
+ closing bug #50823.
+ Added inherit eutils
diff --git a/app-editors/ng/ng-1.5_beta1.ebuild b/app-editors/ng/ng-1.5_beta1.ebuild
index b6efa7893a52..b4368354515e 100644
--- a/app-editors/ng/ng-1.5_beta1.ebuild
+++ b/app-editors/ng/ng-1.5_beta1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Id: ng-1.5_beta1.ebuild,v 1.1 2004/05/15 18:19:20 usata Exp $
+# $Id: ng-1.5_beta1.ebuild,v 1.2 2004/05/15 18:47:45 usata Exp $
+
+inherit eutils
IUSE="canna"
@@ -34,7 +36,9 @@ src_compile() {
local myconf
- myconf="`use_enable canna`"
+ if use canna; then
+ myconf="--enable-canna"
+ fi
econf ${myconf} || die
sed -i -e "s/^#undef NO_BACKUP/#define NO_BACKUP/" config.h \
|| die "sed failed"