summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-22 23:36:15 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-22 23:36:15 +0000
commit2e2b8937a01196a24d5c4fdcbb6d5783fa2a738b (patch)
tree43c38bb63b4164a6615adf91a43afb23bdd3a49c /app-editors/emacs-cvs
parentform unification (diff)
downloadhistorical-2e2b8937a01196a24d5c4fdcbb6d5783fa2a738b.tar.gz
historical-2e2b8937a01196a24d5c4fdcbb6d5783fa2a738b.tar.bz2
historical-2e2b8937a01196a24d5c4fdcbb6d5783fa2a738b.zip
Defaults to use aspell if installed
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/ChangeLog5
-rw-r--r--app-editors/emacs-cvs/Manifest5
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild18
-rw-r--r--app-editors/emacs-cvs/files/40aspell-gentoo.el4
4 files changed, 27 insertions, 5 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 85f2397fa269..577c1db3a002 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.14 2003/09/21 05:00:15 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.15 2003/09/22 23:36:08 usata Exp $
+
+ 23 Sep 2003; Mamoru KOMACHI <usata@gentoo.org> emacs-cvs-21.3.50.ebuild:
+ Defaults to use aspell if installed, see Bug #28527
21 Sep 2003; Mamoru KOMACHI <usata@gentoo.org> emacs-cvs-21.3.50.ebuild:
Emacs can use either ispell or aspell, also suggested in Bug #28527
diff --git a/app-editors/emacs-cvs/Manifest b/app-editors/emacs-cvs/Manifest
index 9fb9ee750a1b..d3f748988a2c 100644
--- a/app-editors/emacs-cvs/Manifest
+++ b/app-editors/emacs-cvs/Manifest
@@ -1,5 +1,6 @@
-MD5 f0950fddc49bcec7f5bc1dc3789e51a8 ChangeLog 2155
-MD5 6fbcf236d3bca2c97c37c775207a239c emacs-cvs-21.3.50.ebuild 2292
+MD5 32e2a9645ef2c649a52b46bb529d8736 ChangeLog 2285
+MD5 0158a2bb63824e163e6de42cdbff7be1 emacs-cvs-21.3.50.ebuild 2519
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-emacs-cvs-21.3.50 0
MD5 0e5a4a35651f5365c6191636a2c26eb7 files/emacs.desktop 190
+MD5 04a64867694a98538309b433c80aaa62 files/40aspell-gentoo.el 80
diff --git a/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild b/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
index 495350391f62..dd005879918c 100644
--- a/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild,v 1.15 2003/09/21 05:00:15 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild,v 1.16 2003/09/22 23:36:08 usata Exp $
ECVS_SERVER="subversions.gnu.org:/cvsroot/emacs"
ECVS_MODULE="emacs"
ECVS_USER="anoncvs"
ECVS_CVS_OPTIONS="-dP"
-inherit cvs
+inherit elisp-common cvs
IUSE="X nls gtk gtk2 Xaw3d gnome spell"
@@ -96,6 +96,11 @@ src_install () {
# fix info documentation
find ${D}/usr/share/info -type f -exec mv {} {}.info \;
+ if has_version 'app-text/aspell' ; then
+ # defaults to aspell if installed
+ elisp-site-file-install ${FILESDIR}/40aspell-gentoo.el
+ fi
+
dodoc BUGS ChangeLog README
if use gnome
@@ -103,5 +108,14 @@ src_install () {
insinto /usr/share/gnome/apps/Application
doins ${FILESDIR}/${DFILE}
fi
+}
+
+pkg_postinst() {
+
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
}
diff --git a/app-editors/emacs-cvs/files/40aspell-gentoo.el b/app-editors/emacs-cvs/files/40aspell-gentoo.el
new file mode 100644
index 000000000000..0106b91d64f9
--- /dev/null
+++ b/app-editors/emacs-cvs/files/40aspell-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; ispell-aspell site-lisp configuration
+
+(setq ispell-program-name "aspell")