summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-14 03:48:44 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-14 03:48:44 +0000
commita18da47bfe2f746aea54c1135872c4e07f17bc84 (patch)
tree4b722d2a13077dc6ac0fb2fcd9d1a5cd240eacb6 /app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild
parentFix to reflect upstream's change from a tarball to a .run makeself archive. A... (diff)
downloadhistorical-a18da47bfe2f746aea54c1135872c4e07f17bc84.tar.gz
historical-a18da47bfe2f746aea54c1135872c4e07f17bc84.tar.bz2
historical-a18da47bfe2f746aea54c1135872c4e07f17bc84.zip
Added to ~ppc-macos. This closes bug #64352.
Diffstat (limited to 'app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild')
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild55
1 files changed, 36 insertions, 19 deletions
diff --git a/app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild b/app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild
index 96bfe6d9c230..12dc0caa93a3 100644
--- a/app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild,v 1.2 2004/10/03 08:20:03 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50-r1.ebuild,v 1.3 2004/10/14 03:48:44 usata Exp $
ECVS_AUTH="ext"
export CVS_RSH="ssh"
@@ -15,6 +15,7 @@ ECVS_SSH_HOST_KEY="savannah.gnu.org,199.232.41.3 ssh-rsa AAAAB3NzaC1yc2EAAAABIwA
inherit elisp-common cvs alternatives flag-o-matic eutils
IUSE="X Xaw3d gif gnome gtk jpeg nls png spell tiff"
+#IUSE="${IUSE} aqua"
S=${WORKDIR}/${ECVS_MODULE}
DESCRIPTION="Emacs is the extensible, customizable, self-documenting real-time display editor."
@@ -44,7 +45,7 @@ PROVIDE="virtual/emacs virtual/editor"
SLOT="21.3.50"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ppc-macos"
DFILE=emacs-${SLOT}.desktop
@@ -52,44 +53,60 @@ src_compile() {
strip-flags
epatch ${FILESDIR}/emacs-subdirs-el-gentoo.diff
+ use ppc-macos && epatch ${FILESDIR}/${P}-nofink.diff
local myconf
use nls || myconf="${myconf} --disable-nls"
- myconf="${myconf} $(use_with X x)"
-
if use X; then
- myconf="${myconf} --with-xpm"
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-xpm --with-toolkit-scroll-bars"
myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
myconf="${myconf} $(use_with gif) $(use_with png)"
if use gtk; then
einfo "Configuring to build with GTK support"
- myconf="${myconf} --with-x-toolkit=gtk
- --with-toolkit-scroll-bars"
+ myconf="${myconf} --with-x-toolkit=gtk"
elif use Xaw3d; then
einfo "Configuring to build with Xaw3d support"
- myconf="${myconf} --with-x-toolkit=athena
- --with-toolkit-scroll-bars"
+ myconf="${myconf} --with-x-toolkit=athena"
else
- einfo "Configuring to build without X toolkit support"
- myconf="${myconf} --without-gtk"
- myconf="${myconf} --with-x-toolkit=no"
- myconf="${myconf} --without-toolkit-scroll-bars"
+ einfo "Configuring to build with lucid toolkit support"
+ myconf="${myconf} --with-x-toolkit=lucid"
fi
fi
+# if use aqua ; then
+# einfo "Configuring to build with Carbon Emacs"
+# econf --enable-debug \
+# --enable-carbon-app=/Applications/Gentoo \
+# --without-x \
+# $(use_with jpeg) $(use_with tiff) \
+# $(use_with gif) $(use_with png) \
+# || die "econf carbon emacs failed"
+# make bootstrap || die "make carbon emacs bootstrap failed"
+# fi
+
econf --enable-debug \
- --program-suffix=-${SLOT} \
- ${myconf} || die
+ --program-suffix=-${PV} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
- make bootstrap || die
+ make bootstrap || die "make emacs bootstrap failed"
}
src_install () {
einstall || die
rm ${D}/usr/bin/emacs-${SLOT}-${SLOT}
+# if use aqua ; then
+# einfo "Installing Carbon Emacs..."
+# dodir /Applications/Gentoo/Emacs.app
+# pushd mac/Emacs.app
+# tar -chf - . | ( cd ${D}/Applications/Gentoo/Emacs.app; tar -xf -)
+# popd
+# fi
+
# fix info documentation
einfo "Fixing info documentation..."
dodir /usr/share/info/emacs-${SLOT}
@@ -117,7 +134,7 @@ src_install () {
if use gnome; then
insinto /usr/share/gnome/apps/Application
- doins ${FILESDIR}/${DFILE}
+ doins ${FILESDIR}/${DFILE} || die "install desktop file failed"
fi
}
@@ -129,9 +146,9 @@ update-alternatives() {
}
pkg_postinst() {
- update-alternatives
+ use ppc-macos || update-alternatives
}
pkg_postrm() {
- update-alternatives
+ use ppc-macos || update-alternatives
}