summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-27 22:18:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-27 22:18:19 +0000
commita43341c90c2f6995791b4fa6bc7374a5a9089127 (patch)
treef561b7f2c7e43c7f14d493cd05b93a8259aa3eb0 /app-editors/bluefish
parentupdate to lastest apache+mod_ssl (diff)
downloadhistorical-a43341c90c2f6995791b4fa6bc7374a5a9089127.tar.gz
historical-a43341c90c2f6995791b4fa6bc7374a5a9089127.tar.bz2
historical-a43341c90c2f6995791b4fa6bc7374a5a9089127.zip
man page/LFH fixes.
Diffstat (limited to 'app-editors/bluefish')
-rw-r--r--app-editors/bluefish/ChangeLog8
-rw-r--r--app-editors/bluefish/bluefish-0.7-r2.ebuild51
-rw-r--r--app-editors/bluefish/files/digest-bluefish-0.7-r21
3 files changed, 59 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index b435d38f4bab..9d86bd01a0d2 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.2 2002/03/12 13:39:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.3 2002/03/27 22:18:19 seemant Exp $
+
+*bluefish-0.7-r2 (27 Mar 2002)
+
+ 27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> bluefish-0.7-r2.ebuild :
+
+ man page/LFH compliance submitted by Matthew Kennedy.
*bluefish-0.7-r1 (12 Mar 2002)
diff --git a/app-editors/bluefish/bluefish-0.7-r2.ebuild b/app-editors/bluefish/bluefish-0.7-r2.ebuild
new file mode 100644
index 000000000000..3cd130f2dbbb
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.7-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7-r2.ebuild,v 1.1 2002/03/27 22:18:19 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use perl && myconf="${myconf} --with-perl"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-autocomplet \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ makefiles=`find . -name Makefile`
+ for f in $makefiles; do
+ mv $f $f.orig
+ sed -e 's#$(prefix)#$(DESTDIR)$(prefix)#' \
+ -e 's#${prefix}#$(DESTDIR)${prefix}#' \
+ -e 's#/usr/share/pixmaps#$(DESTDIR)$(prefix)/share/pixmaps#' \
+ $f.orig > $f
+ done
+
+ make \
+ DESTDIR=${D} \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING INSTALL NEWS README TODO
+ mv manual ${D}usr/share/doc/${PF}
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-0.7-r2 b/app-editors/bluefish/files/digest-bluefish-0.7-r2
new file mode 100644
index 000000000000..d19cb8307e68
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-0.7-r2
@@ -0,0 +1 @@
+MD5 7bb7f7c1a262189cce3675bfd7d5edfe bluefish-0.7.tar.bz2 564856