summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-07-18 21:59:16 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-07-18 21:59:16 +0000
commitd4cd3b31699db71b7a64ed797d6c3b837ff510f0 (patch)
treef135b47afd94866915dbbd574868a3312c4a095c /app-crypt
parentadding amd64 keywors to a large number of packages (diff)
downloadhistorical-d4cd3b31699db71b7a64ed797d6c3b837ff510f0.tar.gz
historical-d4cd3b31699db71b7a64ed797d6c3b837ff510f0.tar.bz2
historical-d4cd3b31699db71b7a64ed797d6c3b837ff510f0.zip
*** empty log message ***
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.2-r11
-rw-r--r--app-crypt/gnupg/gnupg-1.2.2-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.2-r1 b/app-crypt/gnupg/files/digest-gnupg-1.2.2-r1
new file mode 100644
index 000000000000..c9f5676d4406
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.2-r1
@@ -0,0 +1 @@
+MD5 4e1b357b22e1d45d14d340ce03d39b63 gnupg-1.2.2.tar.bz2 2225034
diff --git a/app-crypt/gnupg/gnupg-1.2.2-r1.ebuild b/app-crypt/gnupg/gnupg-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..59836efb853e
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.2-r1.ebuild,v 1.1 2003/07/18 21:59:16 taviso Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha arm hppa"
+IUSE="X zlib ldap nls"
+
+DEPEND="dev-lang/perl
+ X? ( x11-misc/xloadimage )
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ldap || myconf="${myconf} --disable-ldap"
+ use zlib || myconf="${myconf} --with-included-zlib"
+ use X || myconf="${myconf} --disable-photo-viewers"
+
+ #Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog OpenPGP
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod u+s,g-s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}