summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-10-31 15:46:08 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-10-31 15:46:08 +0000
commit6dd3ce0d5a453b99cb5a32d2b874db1fc5fd871d (patch)
tree86df06dd9c5170f03a360fe91ccff3c67b5c8f04 /app-crypt
parentmisc updates (diff)
downloadhistorical-6dd3ce0d5a453b99cb5a32d2b874db1fc5fd871d.tar.gz
historical-6dd3ce0d5a453b99cb5a32d2b874db1fc5fd871d.tar.bz2
historical-6dd3ce0d5a453b99cb5a32d2b874db1fc5fd871d.zip
misc updates
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/Manifest4
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.3-r31
-rw-r--r--app-crypt/gnupg/gnupg-1.2.3-r3.ebuild108
3 files changed, 111 insertions, 2 deletions
diff --git a/app-crypt/gnupg/Manifest b/app-crypt/gnupg/Manifest
index b6b9146de083..613a8d5678a7 100644
--- a/app-crypt/gnupg/Manifest
+++ b/app-crypt/gnupg/Manifest
@@ -1,6 +1,6 @@
MD5 0761192752d3ed8c1ced6a858261eff6 gnupg-1.2.3-r2.ebuild 1626
-MD5 ae07201197cb7a19c8684d8d0898d577 gnupg-1.2.3-r3.ebuild 2843
-MD5 6031944d0b91be207a368a9940c03103 ChangeLog 4707
+MD5 438bd797a5e205a166e724938eec0213 gnupg-1.2.3-r3.ebuild 2932
+MD5 274740a8e9b61f5221059a8cdf8d9720 ChangeLog 5496
MD5 5ffa87354a03beae320d15a7be997529 gnupg-1.2.2-r1.ebuild 1629
MD5 773ecd19392b8f793d7626c9814e1e0b files/digest-gnupg-1.2.2-r1 65
MD5 eecb1b58574b61ddac7c3d12b0143b7d files/digest-gnupg-1.2.3-r2 65
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.3-r3 b/app-crypt/gnupg/files/digest-gnupg-1.2.3-r3
new file mode 100644
index 000000000000..f63dbab6d49f
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.3-r3
@@ -0,0 +1 @@
+MD5 cdca1282d7901f9ddb52f9725b001af2 gnupg-1.2.3.tar.bz2 2294773
diff --git a/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild b/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild
new file mode 100644
index 000000000000..21474e838149
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild,v 1.1 2003/10/31 15:46:04 taviso Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc ~hppa"
+IUSE="X ldap nls static cap"
+
+RDEPEND="!static? ( ldap? ( net-nds/openldap )
+ cap? ( sys-libs/libcap )
+ sys-libs/zlib )
+ X? ( x11-misc/xloadimage )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="cap? ( static? ( >=sys-libs/libcap-1.10-r3 )
+ !static? ( sys-libs/libcap ) )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ !static? ( sys-libs/zlib )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="--enable-external-hkp --enable-static-rnd=linux --libexecdir=/usr/lib"
+
+ # disable native language support
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ # enable LDAP keyserver interface
+ if use ldap; then
+ myconf="${myconf} --enable-ldap"
+ else
+ myconf="${myconf} --disable-ldap"
+ fi
+
+ # enable photo ID viewers
+ # TODO: optional image viewer? --with-photo-viewer=...
+ if use X; then
+ myconf="${myconf} --enable-photo-viewers"
+ else
+ myconf="${myconf} --disable-photo-viewers"
+ fi
+
+ # if we are compiling statically, we might as well use
+ # the included zlib library and remove a dep.
+ # `USE=static` support was requested in #29299
+ if use static; then
+ myconf="${myconf} --with-included-zlib"
+ LDFLAGS="${LDFLAGS} -static"
+ else
+ myconf="${myconf} --without-included-zlib"
+ fi
+
+ # use the linux capability library to minimise security
+ # risks of running setuid root.
+ if use cap; then
+ myconf="${myconf} --with-capabilities"
+ fi
+
+ # Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if ! use sparc; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf}
+ emake
+}
+
+src_install() {
+ einstall libexecdir="${D}/usr/lib/gnupg"
+
+ rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS \
+ README THANKS TODO VERSION doc/{FAQ,HACKING,DETAILS,ChangeLog,OpenPGP,faq.raw}
+
+ docinto sgml
+ dodoc doc/*.sgml
+
+ dohtml doc/faq.html
+
+ chmod u+s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. This may make some sysadmins nervous."
+
+ if use cap; then
+ echo
+ einfo "gpg will use Linux capabilities to set the permitted"
+ einfo "operations, this will minimise the security risks"
+ einfo "associated with running setuid root."
+ echo
+ einfo "You can confirm the capabilities are being set correctly"
+ einfo "with the following command while gpg is running"
+ echo
+ einfo " # getpcaps \`pidof gpg\`"
+ fi
+}