summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-07 09:54:11 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-07 09:54:11 +0000
commit0a59d155246bf37159c6b9b2526ed85a1c5f7d06 (patch)
tree64bb11fb00813208f231859c047fb08f1a1712e4 /app-crypt
parents|/usr/lib/libncurses.so|-lncurses|, fixes bug #12 (diff)
downloadhistorical-0a59d155246bf37159c6b9b2526ed85a1c5f7d06.tar.gz
historical-0a59d155246bf37159c6b9b2526ed85a1c5f7d06.tar.bz2
historical-0a59d155246bf37159c6b9b2526ed85a1c5f7d06.zip
removed old version, new version builds correctly with ssl-des support, also added USE=afs to make it depend on openafs for kerbers-auth to afs
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/kth-krb/files/digest-kth-krb-1.1-r1 (renamed from app-crypt/kth-krb/files/digest-kth-krb-1.1)0
-rw-r--r--app-crypt/kth-krb/kth-krb-1.1-r1.ebuild (renamed from app-crypt/kth-krb/kth-krb-1.1.ebuild)25
2 files changed, 21 insertions, 4 deletions
diff --git a/app-crypt/kth-krb/files/digest-kth-krb-1.1 b/app-crypt/kth-krb/files/digest-kth-krb-1.1-r1
index 4060d9eb5681..4060d9eb5681 100644
--- a/app-crypt/kth-krb/files/digest-kth-krb-1.1
+++ b/app-crypt/kth-krb/files/digest-kth-krb-1.1-r1
diff --git a/app-crypt/kth-krb/kth-krb-1.1.ebuild b/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild
index 1b3222b7379d..1f5df0d79f50 100644
--- a/app-crypt/kth-krb/kth-krb-1.1.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Mikael Hallendal <micke@hallendal.net>
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1.ebuild,v 1.1 2001/12/31 00:48:22 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1-r1.ebuild,v 1.1 2002/01/07 09:54:11 hallski Exp $
S=${WORKDIR}/krb4-${PV}
DESCRIPTION="Kerberos 4 implementation from KTH"
@@ -9,13 +9,20 @@ SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
DEPEND="virtual/glibc
- ssl? ( >=dev-libs/openssl-0.9.6b )"
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ afs? ( >=net-fs/openafs-1.2.2-r7 )"
src_compile() {
local myconf
- if [ "`use ssl`" ] ; then
- myconf="--with-openssl=/usr"
+ myconf=""
+
+ if [ "`use ssl`" ] ; then
+ myconf="${myconf} --with-openssl=/usr"
+ fi
+
+ if [ -z "`use afs`" ] ; then
+ myconf="${myconf} --without-afs-support"
fi
./configure --host=${CHOST} \
@@ -31,6 +38,16 @@ src_install () {
sysconfdir=${D}/etc \
install || die
+ # Doesn't get install otherwise (for some reason, look into this).
+ if [ "`use ssl`" ] ; then
+ cd ${S}/lib/des
+
+ make prefix=${D}/usr/athena \
+ install || die
+
+ cd ${S}
+ fi
+
dodir /etc/env.d
cp ${FILESDIR}/02kth-krb ${D}/etc/env.d