summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 20:39:29 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 20:39:29 +0000
commit1cb73ae8cd01b90097c00edde8374e16497110bd (patch)
treebfe2ee8aea814d1794bccb1c58104b06b70fd462 /app-crypt/johntheripper
parentChanged econf||die to econf (diff)
downloadhistorical-1cb73ae8cd01b90097c00edde8374e16497110bd.tar.gz
historical-1cb73ae8cd01b90097c00edde8374e16497110bd.tar.bz2
historical-1cb73ae8cd01b90097c00edde8374e16497110bd.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-crypt/johntheripper')
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-crypt/johntheripper/johntheripper-1.6.ebuild b/app-crypt/johntheripper/johntheripper-1.6.ebuild
index e7a5db91b1ca..25d785ded1d4 100644
--- a/app-crypt/johntheripper/johntheripper-1.6.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.4 2002/10/17 13:23:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.5 2002/11/30 20:32:53 vapier Exp $
PN0="john"
S=${WORKDIR}/${PN0}-${PV}
@@ -8,11 +8,12 @@ DEBPATCH=${PN0}_${PV}-17.diff.gz
DESCRIPTION="John the Ripper is a fast password cracker."
HOMEPAGE="http://www.openwall.com/${PN0}/"
SRC_URI="${HOMEPAGE}/${PN0}-${PV}.tar.gz
- http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
-IUSE="mmx"
+ http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+IUSE="mmx"
DEPEND=">=sys-devel/binutils-2.8.1.0.15"
@@ -26,15 +27,14 @@ src_compile() {
mv Makefile Makefile.orig
sed -e "s/-m486//" -e "s/-Wall -O2/${CFLAGS}/" \
Makefile.orig > Makefile
- if [ -z "`use mmx`" ]
- then
- emake generic
+ if [ `use mmx` ] ; then
+ emake linux-x86-mmx-elf || die
else
- emake linux-x86-mmx-elf
+ emake generic || die
fi
}
-src_install () {
+src_install() {
dodir /usr/share/${PN0} /etc
insinto /etc
doins run/john.ini debian/john-mail.msg debian/john-mail.conf