summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-05 02:39:55 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-05 02:39:55 +0000
commit57c107173e197780ac36e5aa5060df393ae4a7a2 (patch)
treed0561e9ab9531e2e1aa2d4dab74283cc0939713a /app-cdr
parentgnome-vfs version bump and deps. update. (Gnome2) (diff)
downloadhistorical-57c107173e197780ac36e5aa5060df393ae4a7a2.tar.gz
historical-57c107173e197780ac36e5aa5060df393ae4a7a2.tar.bz2
historical-57c107173e197780ac36e5aa5060df393ae4a7a2.zip
Fixed dependency bug 2793
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/xcdroast/ChangeLog8
-rw-r--r--app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r11
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha10-r1.ebuild55
3 files changed, 63 insertions, 1 deletions
diff --git a/app-cdr/xcdroast/ChangeLog b/app-cdr/xcdroast/ChangeLog
index 34744681a162..7df3d6b4782e 100644
--- a/app-cdr/xcdroast/ChangeLog
+++ b/app-cdr/xcdroast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/xcdroast
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.6 2002/04/25 01:42:15 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.7 2002/06/05 02:39:55 lostlogic Exp $
+
+*xcdroast-0.98_alpha10 (23 Apr 2002)
+
+ 4 Jun 2002; Brandon Low <lostlogic@gentoo.org> xcdroast-0.98_alpha10-r1.ebuild:
+
+ Changed dependency for new version, it don't b0rk now.
*xcdroast-0.98_alpha10 (23 Apr 2002)
diff --git a/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r1 b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r1
new file mode 100644
index 000000000000..82d6570be400
--- /dev/null
+++ b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha10-r1
@@ -0,0 +1 @@
+MD5 6f9ffd30c7ba8f067c2f1bddcc83d7d8 xcdroast-0.98alpha10.tar.gz 749736
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha10-r1.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha10-r1.ebuild
new file mode 100644
index 000000000000..e3c7d35a7620
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha10-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <blutgens@sistina.com>
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha10-r1.ebuild,v 1.1 2002/06/05 02:39:55 lostlogic Exp $
+
+S=${WORKDIR}/xcdroast-0.98alpha10
+DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
+SRC_URI="http://www.xcdroast.org/download/${PN}-0.98alpha10.tar.gz"
+HOMEPAGE="http://www.xcdroast.org/"
+SLOT="0"
+
+# WARNING: cdrtools and mkisofs versions hard coded, see below
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ >=media-libs/gdk-pixbuf-0.16.0
+ >=media-libs/giflib-3.0
+ ~app-cdr/cdrtools-1.11.20"
+
+RDEPEND="~app-cdr/cdrtools-1.11.20"
+
+src_compile () {
+
+ # NOTE: This will need to be updated to work with future versions of
+ # xcdroast (hardcoded versions). The listed dependencies are part
+ # of the cdrtools package.
+ mv xcdroast.h xcdroast.h.orig
+ sed -e 's|CDRECORD_VERSION "1.10"|CDRECORD_VERSION "1.11a19"|' \
+ -e 's|CDDA2WAV_VERSION "1.10"|CDDA2WAV_VERSION "1.11a19"|' \
+ -e 's|READCD_VERSION "1.10"|READCD_VERSION "1.11a19"|' \
+ -e 's|MKISOFS_VERSION "1.14"|MKISOFS_VERSION "1.15a20"|' \
+ xcdroast.h.orig > xcdroast.h || die
+
+ make PREFIX=/usr CC="gcc ${CFLAGS}" || die
+}
+
+src_install () {
+
+ make PREFIX=/usr DESTDIR=${D} install || die
+ chown root.wheel ${D}/usr/bin/xcdrgtk
+ dodoc CHANGELOG COPYING DOCUMENTATION FAQ README* TRANSLATION.HOWTO
+
+ # move man pages to /usr/share/man to be LFH compliant
+ mv ${D}/usr/man ${D}/usr/share
+}
+
+pkg_postinst () {
+
+ einfo "Due to limitations in the xcdroast program, the version of cdrtools"
+ einfo "that it depends on must be hardcoded in the xcdroast program. This"
+ einfo "means you must have a specific version of cdrtools installed if you"
+ einfo "plan to use xcdroast. You may need to 'pin' the version of cdrtools"
+ einfo "in use. (See the portage manual for details)"
+
+}