summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-04-16 09:06:33 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-04-16 09:06:33 +0000
commit11e0d6ce0d042ff0ea7ecd37fb4c396448e96a7d (patch)
tree7fa8d1e863946b011b364c17f28d5eb569bd62d1 /app-cdr/xcdroast
parentmasking new portage (diff)
downloadhistorical-11e0d6ce0d042ff0ea7ecd37fb4c396448e96a7d.tar.gz
historical-11e0d6ce0d042ff0ea7ecd37fb4c396448e96a7d.tar.bz2
historical-11e0d6ce0d042ff0ea7ecd37fb4c396448e96a7d.zip
xcdroast hardcoded dependency versions fix
Diffstat (limited to 'app-cdr/xcdroast')
-rw-r--r--app-cdr/xcdroast/ChangeLog8
-rw-r--r--app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha9-r11
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha9-r1.ebuild52
3 files changed, 60 insertions, 1 deletions
diff --git a/app-cdr/xcdroast/ChangeLog b/app-cdr/xcdroast/ChangeLog
index 913d7618a513..b6ef5f81b5cb 100644
--- a/app-cdr/xcdroast/ChangeLog
+++ b/app-cdr/xcdroast/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-cdr/xcdroast
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.2 2002/04/12 16:57:43 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.3 2002/04/16 09:06:33 blocke Exp $
+*xcdroast-0.98_alpha9-r1 (16 Apr 2002)
+
+ 16 Apr 2002; Bruce A. Locke <blocke@shivan.org> xcdroast-0.98_alpha9-r1.ebuild:
+
+ Fixed xcdroast's hardcoded dependency versions to work with a newer version
+ of cdrtools (hardcoding is because of xcdroast itself, not our packaging)
*xcdroast-0.98_alpha9 (11 Apr 2002)
diff --git a/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha9-r1 b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha9-r1
new file mode 100644
index 000000000000..bbd08da104df
--- /dev/null
+++ b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha9-r1
@@ -0,0 +1 @@
+MD5 543d3237e7109572f5fcb6bdc6cf3e44 xcdroast-0.98alpha9.tar.gz 649469
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha9-r1.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha9-r1.ebuild
new file mode 100644
index 000000000000..0d89c36ad6f2
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha9-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <blutgens@sistina.com>
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha9-r1.ebuild,v 1.1 2002/04/16 09:06:33 blocke Exp $
+
+S=${WORKDIR}/xcdroast-0.98alpha9
+DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
+SRC_URI="http://www.xcdroast.org/download/${PN}-0.98alpha9.tar.gz"
+HOMEPAGE="http://www.xcdroast.org/"
+SLOT="0"
+
+# WARNING: cdrtools and mkisofs versions hard coded, see below
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ =dev-libs/glib-1.2*
+ >=media-libs/imlib-1.9.10-r1
+ >=media-libs/giflib-3.0
+ ~app-cdr/cdrtools-1.11.12"
+
+RDEPEND="~app-cdr/cdrtools-1.11.12"
+
+src_compile () {
+
+ # NOTE: This will need to be updated to work with future versions of
+ # xcdroast (hardcoded versions). The listed dependencies are part
+ # of the cdrtools package.
+ mv xcdroast.h xcdroast.h.orig
+ sed -e 's|CDRECORD_VERSION "1.10"|CDRECORD_VERSION "1.11a12"|' \
+ -e 's|CDDA2WAV_VERSION "1.10"|CDDA2WAV_VERSION "1.11a12"|' \
+ -e 's|READCD_VERSION "1.10"|READCD_VERSION "1.11a12"|' \
+ -e 's|MKISOFS_VERSION "1.14"|MKISOFS_VERSION "1.15a12"|' \
+ xcdroast.h.orig > xcdroast.h || die
+
+ make PREFIX=/usr CC="gcc ${CFLAGS}" || die
+}
+
+src_install () {
+
+ make PREFIX=/usr DESTDIR=${D} install || die
+ chown root.wheel ${D}/usr/bin/xcdrgtk
+ dodoc CHANGELOG COPYING DOCUMENTATION FAQ README* TRANSLATION.HOWTO
+}
+
+pkg_postinst () {
+
+ einfo "Due to limitations in the xcdroast program, the version of cdrtools"
+ einfo "that it depends on must be hardcoded in the xcdroast program. This"
+ einfo "means you must have a specific version of cdrtools installed if you"
+ einfo "plan to use xcdroast. You may need to 'pin' the version of cdrtools"
+ einfo "in use. (See the portage manual for details)"
+
+}