summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-02 22:49:38 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-02 22:49:38 +0000
commit7a8162762a455ea8f6e7efb290847a5381b549fe (patch)
tree52d3e8d30548c94e87327f6b964445741aadda57 /app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild
parentFix compilation on fbsd, bug #256958. (diff)
downloadhistorical-7a8162762a455ea8f6e7efb290847a5381b549fe.tar.gz
historical-7a8162762a455ea8f6e7efb290847a5381b549fe.tar.bz2
historical-7a8162762a455ea8f6e7efb290847a5381b549fe.zip
Fix etc installation prefix. Thanks to billie for the report.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild')
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild118
1 files changed, 118 insertions, 0 deletions
diff --git a/app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild b/app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild
new file mode 100644
index 000000000000..daf47798e53e
--- /dev/null
+++ b/app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha57-r1.ebuild,v 1.1 2009/02/02 22:49:38 loki_val Exp $
+
+EAPI=2
+
+inherit multilib eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
+HOMEPAGE="http://cdrecord.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/alpha/${P/_alpha/a}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="unicode acl"
+
+DEPEND="virtual/libc
+ acl? ( sys-apps/acl )
+ !app-cdr/dvdrtools
+ !app-cdr/cdrkit"
+RDEPEND="${DEPEND}"
+
+PROVIDE="virtual/cdrtools"
+
+S="${WORKDIR}/${PN}-2.01.01"
+
+src_prepare() {
+ #"Adjust paths. Upstream is clearly on drugs, hardcoding paths into .c files.
+ sed -i -e 's:opt/schily:usr:' \
+ $(grep -l --include='*.1' --include='*.8' -r 'opt/schily' .) \
+ $(grep -l --include='*.c' --include='*.h' -r 'opt/schily' .) \
+ || die "404 on opt-schily sed"
+
+ sed -i -e "s:\(^INSDIR=\t\tshare/doc/\):\1${PF}/:" \
+ $(grep -l -r 'INSDIR.\+doc' .) \
+ || die "404 on doc sed"
+
+ # Upstream should be hanged from the yardarm, possibly keelhauled for
+ # not respecting libdir.
+ sed -i -e "s:\(^INSDIR=\t\t\)lib:\1$(get_libdir):" \
+ $(grep -l -r '^INSDIR.\+lib\(/siconv\)\?$' .) \
+ || die "404 on multilib-sed"
+
+ # See previous comment s/libdir/--disable-static/
+ sed -i -e 's:include\t\t.*rules.lib::' \
+ $(grep -l -r '^include.\+rules\.lib' .) \
+ || die "404 on rules sed"
+ #Remove profiled make files (wtf?)
+ rm -f $(find . -name '*_p.mk') || die "rm failed"
+
+ epatch "${FILESDIR}"/${PN}-2.01.01a03-warnings.patch
+ epatch "${FILESDIR}"/${PN}-2.01.01_alpha50-asneeded.patch
+
+ #Schily make setup
+ cd "${S}"/DEFAULTS
+ local MYARCH="linux"
+
+ sed -i "s:/opt/schily:/usr:g" Defaults.${MYARCH} || die "sed schily-opt failed"
+ sed -i "s:/usr/src/linux/include::g" Defaults.${MYARCH} || die "sed linux-include failed"
+ sed -i "/RUNPATH/ c\RUNPATH= " Defaults.${MYARCH} || die "sed RUNPATH failed"
+
+ # For dynamic linking:
+ sed -i "s:static:dynamic:" Defaults.${MYARCH} || die "sed static-remove failed"
+
+ # lame symlinks that all point to the same thing
+ cd "${S}"/RULES
+ local t
+ for t in ppc64 sh4 s390x ; do
+ ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
+ ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
+ done
+}
+
+src_configure() { : ; }
+
+src_compile() {
+ local ACL="-lacl"
+ if use unicode; then
+ local flags="$(test-flags -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
+ if [[ -n ${flags} ]]; then
+ append-flags ${flags}
+ else
+ ewarn "Your compiler does not support the options required to build"
+ ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
+ fi
+ fi
+
+ if ! use acl
+ then
+ CFLAGS="${CFLAGS} -DNO_ACL"
+ ACL=""
+ fi
+ #If not built with -j1, "sometimes" cdda2wav will not be built. Nasty bug.
+ emake -j1 CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" LIB_ACL_TEST="${ACL}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake -j1 MANDIR="share/man" INS_BASE="${D}/usr/" INS_RBASE="${D}" install
+
+ #These symlinks are for compat with cdrkit.
+ dosym schily /usr/include/scsilib
+ dosym ../scg /usr/include/schily/scg
+
+ dodoc ABOUT Changelog README README.linux-shm START READMEs/README.linux || die "dodoc cdrtools"
+
+ cd "${S}"/cdda2wav
+ docinto cdda2wav
+ dodoc FAQ Frontends HOWTOUSE TODO || die "dodoc cdda2wav"
+
+}
+
+pkg_postinst() {
+ echo
+ einfo "The command line option 'dev=/dev/hdX' (X is the name of your drive)"
+ einfo "should be used for IDE CD writers. And make sure that the permissions"
+ einfo "on this device are set properly and your user is in the correct group."
+}