summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-03 19:35:52 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-03 19:35:52 +0000
commitc28bce969f72954739a1974807817ddaf640ad86 (patch)
tree8bdc9acecc0876e1ecc31d5108f6d454d3108840 /app-arch
parentVersion bumped. (diff)
downloadhistorical-c28bce969f72954739a1974807817ddaf640ad86.tar.gz
historical-c28bce969f72954739a1974807817ddaf640ad86.tar.bz2
historical-c28bce969f72954739a1974807817ddaf640ad86.zip
Version bumped.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/flexbackup/Manifest4
-rw-r--r--app-arch/flexbackup/files/digest-flexbackup-1.0.51
-rw-r--r--app-arch/flexbackup/flexbackup-1.0.5.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/app-arch/flexbackup/Manifest b/app-arch/flexbackup/Manifest
index a292df36a9f0..c269f4c164b7 100644
--- a/app-arch/flexbackup/Manifest
+++ b/app-arch/flexbackup/Manifest
@@ -1,5 +1,5 @@
-MD5 df29a45825f62b77d5cdc33e1b53bdda ChangeLog 735
-MD5 0aa6be6b1a9a7263c769bb2f751a9267 flexbackup-1.0.5.ebuild 1004
+MD5 1958ffa3b21250b19982387ccb4ede61 ChangeLog 862
+MD5 c71d87c579eda2ae84fe2371c299e0f0 flexbackup-1.0.5.ebuild 1004
MD5 0aa6be6b1a9a7263c769bb2f751a9267 flexbackup-1.0.4.ebuild 1004
MD5 781ed6589b3f05a5a6f376a75ebc9493 flexbackup-1.1.7.ebuild 1004
MD5 14858ea6950835f29fa80e2921940b3b files/Makefile-gentoo.diff 397
diff --git a/app-arch/flexbackup/files/digest-flexbackup-1.0.5 b/app-arch/flexbackup/files/digest-flexbackup-1.0.5
new file mode 100644
index 000000000000..5ec0911052ed
--- /dev/null
+++ b/app-arch/flexbackup/files/digest-flexbackup-1.0.5
@@ -0,0 +1 @@
+MD5 0787ef8d3106f98404a8bb60a0822ab4 flexbackup-1.0.5.tar.gz 60605
diff --git a/app-arch/flexbackup/flexbackup-1.0.5.ebuild b/app-arch/flexbackup/flexbackup-1.0.5.ebuild
new file mode 100644
index 000000000000..5b72e3bbca7b
--- /dev/null
+++ b/app-arch/flexbackup/flexbackup-1.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License
+# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/flexbackup-1.0.5.ebuild,v 1.1 2003/07/03 19:35:38 mholzer Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Flexible backup script using perl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc"
+RDEPEND="app-arch/afio
+ app-arch/mt-st
+ app-arch/dump
+ sys-apps/findutils
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ epatch ${FILESDIR}/Makefile-gentoo.diff
+ emake || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CREDITS INSTALL README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "now edit your /etc/${PN}.conf"
+ einfo "if you are using devfs, the tape device"
+ einfo "should be set to /dev/tapes/tape0/mtn"
+ einfo ""
+}