summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-20 18:48:36 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-20 18:48:36 +0000
commit99cd1c9b4a8e81bb2f6da58c6b3fc774375c3822 (patch)
treeb9e31a8c4d8bff38fdd88fbbf92aa8bf57f01f7d /app-arch
parentarm/s390/sh stable (diff)
downloadhistorical-99cd1c9b4a8e81bb2f6da58c6b3fc774375c3822.tar.gz
historical-99cd1c9b4a8e81bb2f6da58c6b3fc774375c3822.tar.bz2
historical-99cd1c9b4a8e81bb2f6da58c6b3fc774375c3822.zip
old
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.2 x86_64
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/gzip-1.3.12.ebuild49
-rw-r--r--app-arch/lzma-utils/lzma-utils-4.32.5.ebuild45
2 files changed, 0 insertions, 94 deletions
diff --git a/app-arch/gzip/gzip-1.3.12.ebuild b/app-arch/gzip/gzip-1.3.12.ebuild
deleted file mode 100644
index 8c0d63f7509e..000000000000
--- a/app-arch/gzip/gzip-1.3.12.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.12.ebuild,v 1.12 2007/07/20 16:34:15 uberlord Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/"
-SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
- mirror://gnu/gzip/${P}.tar.gz
- mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
- epatch "${FILESDIR}"/gnulib-futimens-rename.patch
- epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
- sed -i 's:\<futimens\>:gl_futimens:' gzip.c
-}
-
-src_compile() {
- use static && append-flags -static
- # avoid text relocation in gzip
- use pic && export DEFS="NO_ASM"
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc ChangeLog NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
-
- # keep most things in /usr, just the fun stuff in /
- dodir /bin
- mv "${D}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${D}"/bin/ || die
-}
diff --git a/app-arch/lzma-utils/lzma-utils-4.32.5.ebuild b/app-arch/lzma-utils/lzma-utils-4.32.5.ebuild
deleted file mode 100644
index 40a606aa9d36..000000000000
--- a/app-arch/lzma-utils/lzma-utils-4.32.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma-utils/lzma-utils-4.32.5.ebuild,v 1.9 2008/05/10 08:35:08 vapier Exp $
-
-# Remember: we cannot leverage autotools in this ebuild in order
-# to avoid circular deps with autotools
-
-inherit eutils
-
-MY_P="lzma-${PV/_}"
-DESCRIPTION="LZMA interface made easy"
-HOMEPAGE="http://tukaani.org/lzma/"
-SRC_URI="http://tukaani.org/lzma/${MY_P}.tar.gz
- nocxx? ( mirror://gentoo/${P}-nocxx.patch.bz2 )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nocxx"
-
-RDEPEND="!app-arch/lzma"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if use nocxx ; then
- epatch "${WORKDIR}"/${P}-nocxx.patch
- epunt_cxx
- fi
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog NEWS README THANKS
- use nocxx && newbin "${FILESDIR}"/lzma-nocxx.sh lzma
-}
-
-pkg_postinst() {
- if use nocxx ; then
- ewarn "You have a neutered lzma package install due to USE=nocxx."
- ewarn "You will only be able to unpack lzma archives."
- fi
-}