summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-04 23:20:57 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-04 23:20:57 +0000
commiteeeb1e527d33278b154b45186c6960c5a4288c66 (patch)
tree053e1d45c0e0a4a965a895cd81182bc50e0cee5a /app-arch/zpaq-extras
parentImporting zpaq archiver from Sunrise as per bug #278021. The ebuild was updat... (diff)
downloadhistorical-eeeb1e527d33278b154b45186c6960c5a4288c66.tar.gz
historical-eeeb1e527d33278b154b45186c6960c5a4288c66.tar.bz2
historical-eeeb1e527d33278b154b45186c6960c5a4288c66.zip
Importing zpaq archiver extra compression profiles from Sunrise as per bug #278021.
Package-Manager: portage-2.2.0_alpha12_p8/cvs/Linux x86_64
Diffstat (limited to 'app-arch/zpaq-extras')
-rw-r--r--app-arch/zpaq-extras/ChangeLog11
-rw-r--r--app-arch/zpaq-extras/metadata.xml9
-rw-r--r--app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild41
3 files changed, 61 insertions, 0 deletions
diff --git a/app-arch/zpaq-extras/ChangeLog b/app-arch/zpaq-extras/ChangeLog
new file mode 100644
index 000000000000..b75bf7b3fe1f
--- /dev/null
+++ b/app-arch/zpaq-extras/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-arch/zpaq-extras
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/ChangeLog,v 1.1 2011/01/04 23:20:57 mgorny Exp $
+
+*zpaq-extras-0_p20100426 (04 Jan 2011)
+
+ 04 Jan 2011; Michał Górny <mgorny@gentoo.org>
+ +zpaq-extras-0_p20100426.ebuild, +metadata.xml:
+ Importing zpaq archiver extra compression profiles from Sunrise as per bug
+ #278021.
+
diff --git a/app-arch/zpaq-extras/metadata.xml b/app-arch/zpaq-extras/metadata.xml
new file mode 100644
index 000000000000..af81389004c1
--- /dev/null
+++ b/app-arch/zpaq-extras/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild b/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
new file mode 100644
index 000000000000..1ec944496bb5
--- /dev/null
+++ b/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild,v 1.1 2011/01/04 23:20:57 mgorny Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A set of additional compression profiles for app-arch/zpaq"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/bwt_j3.zip
+ http://mattmahoney.net/dc/bwt_slowmode1.zip
+ http://mattmahoney.net/dc/bmp_j4.zip
+ http://mattmahoney.net/dc/exe_j1.zip
+ http://mattmahoney.net/dc/jpg_test2.zip
+ http://mattmahoney.net/dc/fast.cfg"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ tc-export CXX
+ progs='bwtpre bwt_ jpeg_jo exe_jo'
+ emake ${progs} || die
+
+ sed \
+ -e 's:^pcomp zpaq r:pcomp /usr/bin/zpaq r/usr/share/zpaq/:' \
+ -e 's:^pcomp \([^/]\):pcomp /usr/libexec/zpaq/\1:' \
+ -i *.cfg || die
+}
+
+src_install() {
+ exeinto /usr/libexec/zpaq
+ doexe ${progs} || die
+
+ insinto /usr/share/zpaq
+ doins *.cfg "${DISTDIR}"/fast.cfg || die
+}