summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-21 10:07:44 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-21 10:07:44 +0000
commit4e7e1ec5728be0f78bc8ea2db6bad446f46138c6 (patch)
tree3c4e4ac9f3f5c53ff66f32cf6231fb79726749b6 /app-arch/zip
parentAutomated update of use.local.desc (diff)
downloadhistorical-4e7e1ec5728be0f78bc8ea2db6bad446f46138c6.tar.gz
historical-4e7e1ec5728be0f78bc8ea2db6bad446f46138c6.tar.bz2
historical-4e7e1ec5728be0f78bc8ea2db6bad446f46138c6.zip
old
Diffstat (limited to 'app-arch/zip')
-rw-r--r--app-arch/zip/files/zip-2.31-make.patch21
-rw-r--r--app-arch/zip/zip-2.32.ebuild46
2 files changed, 0 insertions, 67 deletions
diff --git a/app-arch/zip/files/zip-2.31-make.patch b/app-arch/zip/files/zip-2.31-make.patch
deleted file mode 100644
index 3b0606457e30..000000000000
--- a/app-arch/zip/files/zip-2.31-make.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- zip-2.31/unix/Makefile
-+++ zip-2.31/unix/Makefile
-@@ -13,15 +13,15 @@
-
- list: all
-
--MAKE = make -f unix/Makefile
-+MAKE := $(MAKE) -f unix/Makefile
- SHELL = /bin/sh
- LN = ln -s
-
- # (to use the Gnu compiler, change cc to gcc in CC)
--CC = cc
-+CC ?= gcc
- BIND = $(CC)
- AS = $(CC) -c
--CPP = /lib/cpp
-+CPP ?= $(CC)
- EXE =
-
- # probably can change this to 'install' if you have it
diff --git a/app-arch/zip/zip-2.32.ebuild b/app-arch/zip/zip-2.32.ebuild
deleted file mode 100644
index 590ad78f393c..000000000000
--- a/app-arch/zip/zip-2.32.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.32.ebuild,v 1.12 2007/06/13 00:31:02 vapier Exp $
-
-inherit toolchain-funcs eutils flag-o-matic
-
-DESCRIPTION="Info ZIP (encryption support)"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="ftp://ftp.info-zip.org/pub/infozip/src/zip${PV//.}.tar.gz"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="crypt"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/zip-2.3-unix_configure-pic.patch
- epatch "${FILESDIR}"/${PN}-2.31-exec-stack.patch
- epatch "${FILESDIR}"/${PN}-2.31-make.patch
- use crypt || append-flags -DNO_CRYPT
- sed -i \
- -e "s:-O[23]:${CFLAGS}:" \
- -e '/^LFLAGS1=""/s:=.*:="${LDFLAGS}":' \
- unix/configure
-}
-
-src_compile() {
- tc-export CC CPP
- emake -f unix/Makefile generic || die
-}
-
-src_install() {
- dobin zip zipnote zipsplit || die
- doman man/zip.1
- dosym zip.1 /usr/share/man/man1/zipnote.1
- dosym zip.1 /usr/share/man/man1/zipzplit.1
- if use crypt ; then
- dobin zipcloak || die
- dosym zip.1 /usr/share/man/man1/zipcloak.1
- fi
- dodoc BUGS CHANGES MANUAL README TODO WHATSNEW WHERE proginfo/*.txt
-}