summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:58:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:58:29 +0000
commit1e8192d57ee0f26963c35400527aed9df2a29175 (patch)
treeed34006229823f737efa6419dc2c998b53b3e4cf /app-arch/zip
parentmodernized (diff)
downloadhistorical-1e8192d57ee0f26963c35400527aed9df2a29175.tar.gz
historical-1e8192d57ee0f26963c35400527aed9df2a29175.tar.bz2
historical-1e8192d57ee0f26963c35400527aed9df2a29175.zip
modernised
Diffstat (limited to 'app-arch/zip')
-rw-r--r--app-arch/zip/zip-2.3-r1.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/app-arch/zip/zip-2.3-r1.ebuild b/app-arch/zip/zip-2.3-r1.ebuild
index 263b84757887..039ccbedb8a6 100644
--- a/app-arch/zip/zip-2.3-r1.ebuild
+++ b/app-arch/zip/zip-2.3-r1.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.3-r1.ebuild,v 1.9 2002/08/02 04:50:11 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.3-r1.ebuild,v 1.10 2002/08/02 04:57:53 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Info ZIP"
SRC_URI="http://www.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/${PN}23.tar.gz"
-SLOT="0"
HOMEPAGE="ftp://ftp.freesoftware.com/pub/infozip/Zip.html"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
LICENSE="Info-ZIP"
DEPEND="virtual/glibc"
-KEYWORDS="x86 ppc"
src_unpack() {
-
- unpack ${A}
- cd ${S}/unix
- cp Makefile Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
-
+ unpack ${A}
+ cd ${S}/unix
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
}
-src_compile() {
+src_compile() {
make -f unix/Makefile generic_gcc || die
-
}
src_install () {
-
dobin zip zipcloak zipnote zipsplit
doman man/zip.1
dodoc BUGS CHANGES LICENSE MANUAL README TODO WHATSNEW WHERE
-
}
-