summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-02-09 19:35:01 +0000
committerChristoph Mende <angelos@gentoo.org>2009-02-09 19:35:01 +0000
commitcb1f32cc2f74db141657b3096ac19c56f6e5810d (patch)
tree10269af152cc70ef9221812cc722f858483ad294 /app-arch/xarchiver/xarchiver-0.5.2.ebuild
parentStable on alpha, bug #258230 (diff)
downloadhistorical-cb1f32cc2f74db141657b3096ac19c56f6e5810d.tar.gz
historical-cb1f32cc2f74db141657b3096ac19c56f6e5810d.tar.bz2
historical-cb1f32cc2f74db141657b3096ac19c56f6e5810d.zip
Cleaned up and applied a patch to fix stack smashing (bug 256539 by Frederic Johansson)
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-arch/xarchiver/xarchiver-0.5.2.ebuild')
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.2.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-arch/xarchiver/xarchiver-0.5.2.ebuild b/app-arch/xarchiver/xarchiver-0.5.2.ebuild
index f9a478700aeb..44e6e47ac70c 100644
--- a/app-arch/xarchiver/xarchiver-0.5.2.ebuild
+++ b/app-arch/xarchiver/xarchiver-0.5.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/xarchiver-0.5.2.ebuild,v 1.7 2009/02/04 21:12:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/xarchiver-0.5.2.ebuild,v 1.8 2009/02/09 19:35:01 angelos Exp $
EAPI=1
-inherit fdo-mime gnome2-utils
+inherit eutils fdo-mime gnome2-utils
-DESCRIPTION="a GTK+ based and advanced archive manager that can be used with Thunar file manager."
+DESCRIPTION="a GTK+ based and advanced archive manager that can be used with Thunar"
HOMEPAGE="http://xarchiver.xfce.org"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -21,13 +21,19 @@ DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-stack-smash.patch
+}
+
src_compile() {
econf --disable-dependency-tracking $(use_enable debug)
- emake || die "emake failed."
+ emake || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
}