summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-15 14:57:58 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-15 14:57:58 +0000
commit9a7c17b4cc9c321149d3051e463c88c8209f193d (patch)
tree1712e12e83ac40ea312379476ad01d2632ebfb59 /app-arch/dpkg
parentversion bump (diff)
downloadhistorical-9a7c17b4cc9c321149d3051e463c88c8209f193d.tar.gz
historical-9a7c17b4cc9c321149d3051e463c88c8209f193d.tar.bz2
historical-9a7c17b4cc9c321149d3051e463c88c8209f193d.zip
version bump
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/Manifest4
-rw-r--r--app-arch/dpkg/dpkg-1.10.10.ebuild35
-rw-r--r--app-arch/dpkg/files/digest-dpkg-1.10.101
-rw-r--r--app-arch/dpkg/files/dpkg-1.10.10.patch76
4 files changed, 114 insertions, 2 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
index 6e13efc6b5a1..54d43fa9dcc3 100644
--- a/app-arch/dpkg/Manifest
+++ b/app-arch/dpkg/Manifest
@@ -1,6 +1,6 @@
-MD5 da7e803f077cb10e9caa9e2e6bab2a88 ChangeLog 560
+MD5 7d3f1239eb85d8e4ae636107daea2971 ChangeLog 560
MD5 2e681d63dbfe9a5468eea91b7a6408d3 dpkg-1.10.9.ebuild 1617
-MD5 1600b8731b8ad691514add11195a3c98 dpkg-1.10.10.ebuild 848
+MD5 2e23bd3a4bce07d496bbfa17032c70cb dpkg-1.10.10.ebuild 944
MD5 b6b7d00486039c2e10670937dc5266bb files/digest-dpkg-1.10.9 64
MD5 982d82b477842d92e5184b3856a63d74 files/dpkg-1.10.10.patch 2112
MD5 0c6bf832b2ed2a0c94a7879c3427c6a1 files/digest-dpkg-1.10.10 65
diff --git a/app-arch/dpkg/dpkg-1.10.10.ebuild b/app-arch/dpkg/dpkg-1.10.10.ebuild
new file mode 100644
index 000000000000..3e8e05c48c4e
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.10.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.10.10.ebuild,v 1.1 2003/07/15 14:57:48 lanius Exp $
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SRC_URI="http://ftp.debian.org/debian/pool/main/d/dpkg/dpkg_${PV}.tar.gz"
+RDEPEND=">=dev-lang/perl-5.6.0
+ >=sys-libs/ncurses-5.2-r7
+ >=sys-libs/zlib-1.1.4" #app-text/sgmltools-lite?
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5"
+
+S="${WORKDIR}/dpkg-${PV}"
+
+src_compile() {
+ cd main
+ ln -s ../archtable
+ cd ..
+ epatch ${FILESDIR}/${P}.patch
+ ./configure || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodir /etc/alternatives
+ insinto /etc/alternatives
+ doins scripts/README.alternatives
+ dodoc ABOUT-NLS COPYING ChangeLog INSTALL THANKS TODO
+}
diff --git a/app-arch/dpkg/files/digest-dpkg-1.10.10 b/app-arch/dpkg/files/digest-dpkg-1.10.10
new file mode 100644
index 000000000000..3bbc3b04f22b
--- /dev/null
+++ b/app-arch/dpkg/files/digest-dpkg-1.10.10
@@ -0,0 +1 @@
+MD5 e5cdb9e0f4de30fa9d5a8a0f97d23b0f dpkg_1.10.10.tar.gz 1547158
diff --git a/app-arch/dpkg/files/dpkg-1.10.10.patch b/app-arch/dpkg/files/dpkg-1.10.10.patch
new file mode 100644
index 000000000000..dfc1751b23b9
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.10.10.patch
@@ -0,0 +1,76 @@
+--- main/Makefile.in 2003-05-11 18:23:18.000000000 +0200
++++ main.new/Makefile.in 2003-05-11 18:23:42.000000000 +0200
+@@ -1,10 +1,10 @@
+ VPATH = @srcdir@
+ srcdir = @srcdir@
+-top_srcdir = @top_srcdir@
+ top_builddir = ..
+
+ default: all
+ include ../Makefile.conf
++top_srcdir = @top_srcdir@
+
+ CXX_SOURCES = basecmds.cc baselist.cc basetop.cc bindings.cc curkeys.cc \
+ main.cc methkeys.cc methlist.cc method.cc methparse.cc \
+--- dselect/curkeys.cc 2003-05-11 18:44:26.000000000 +0200
++++ dselect/curkeys.cc.1 2003-05-11 18:43:57.000000000 +0200
+@@ -19,6 +19,8 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#define NCURSES_WGETCH_EVENTS
++
+ extern "C" {
+ #include <config.h>
+ #include <dpkg.h>
+--- doc/Makefile.in 2003-05-11 18:47:18.000000000 +0200
++++ doc.new/Makefile.in 2003-05-11 18:47:31.000000000 +0200
+@@ -1,10 +1,10 @@
+ VPATH = @srcdir@
+ srcdir = @srcdir@
+-top_srcdir = @top_srcdir@
+
+ default: all
+
+ include ../Makefile.conf
++top_srcdir = @top_srcdir@
+
+ ifeq (@USE_SGML_DOC@, true)
+ all: internals.html/index.html
+--- Makefile.in 2003-05-11 19:00:49.000000000 +0200
++++ Makefile.in.new 2003-05-11 19:00:40.000000000 +0200
+@@ -10,7 +10,7 @@
+ include Makefile.conf
+
+ SUBDIRS = include optlib lib dpkg-deb split scripts utils main \
+- @DSELECTDIR@ po methods man doc
++ @DSELECTDIR@ po methods man
+
+ all: version.h all-recursive
+
+--- Makefile.conf.in 2003-05-11 19:06:03.000000000 +0200
++++ Makefile.conf.in.new 2003-05-11 19:06:29.000000000 +0200
+@@ -43,7 +43,7 @@
+ subdir = $(patsubst $(top_srcdir)/%,%,$(srcdir))/
+ endif
+ PERL = @PERL@
+-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
++mkinstalldirs = /usr/share/automake-1.5/mkinstalldirs
+ LN = @LN_S@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+--- man/Makefile.in 2003-05-11 19:11:06.000000000 +0200
++++ man.new/Makefile.in 2003-05-11 19:11:18.000000000 +0200
+@@ -1,11 +1,11 @@
+ VPATH = @srcdir@
+ srcdir = @srcdir@
+-top_srcdir = @top_srcdir@
+
+ SUBDIRS = de en fr ja pt_BR ru sv
+
+ default: all
+ include ../Makefile.conf
++top_srcdir = @top_srcdir@
+
+ clean: clean-recursive
+