summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 15:40:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 15:40:59 +0000
commit16ae09eb12e35b214c95131449cc51617811e63b (patch)
treef211196891e7b33cf82595d1f621e6b5c2a174bd /app-arch/cksfv
parentUpstream requested minor changes (diff)
downloadhistorical-16ae09eb12e35b214c95131449cc51617811e63b.tar.gz
historical-16ae09eb12e35b214c95131449cc51617811e63b.tar.bz2
historical-16ae09eb12e35b214c95131449cc51617811e63b.zip
you fools need to learn how to inherit eutils for epatch
Diffstat (limited to 'app-arch/cksfv')
-rw-r--r--app-arch/cksfv/cksfv-1.3.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-arch/cksfv/cksfv-1.3.ebuild b/app-arch/cksfv/cksfv-1.3.ebuild
index 42a40367f862..7312892b5830 100644
--- a/app-arch/cksfv/cksfv-1.3.ebuild
+++ b/app-arch/cksfv/cksfv-1.3.ebuild
@@ -1,25 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cksfv/cksfv-1.3.ebuild,v 1.11 2004/05/25 20:41:22 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cksfv/cksfv-1.3.ebuild,v 1.12 2004/05/28 15:40:59 vapier Exp $
-DESCRIPTION="cksfv: SFV checksum utility (simple file verification)"
-SRC_URI="http://www.fodder.org/cksfv/${P}.tar.gz"
+inherit eutils
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
HOMEPAGE="http://www.fodder.org/cksfv/"
+SRC_URI="http://www.fodder.org/cksfv/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha ~amd64"
+IUSE=""
DEPEND="virtual/glibc"
src_compile() {
# patch for int size problems on 64bit systems
use amd64 && epatch ${FILESDIR}/${P}-64bit-fix.patch
-
emake || die
}
src_install() {
- dobin src/cksfv
- dodoc COPYING ChangeLog INSTALL README TODO
+ dobin src/cksfv || die
+ dodoc ChangeLog INSTALL README TODO
}